summaryrefslogtreecommitdiff
path: root/app-emulation/winetricks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /app-emulation/winetricks
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'app-emulation/winetricks')
-rw-r--r--app-emulation/winetricks/Manifest4
-rw-r--r--app-emulation/winetricks/winetricks-20201206.ebuild91
-rw-r--r--app-emulation/winetricks/winetricks-99999999.ebuild12
3 files changed, 99 insertions, 8 deletions
diff --git a/app-emulation/winetricks/Manifest b/app-emulation/winetricks/Manifest
index ed0ad53c15d7..b78fe113ecd7 100644
--- a/app-emulation/winetricks/Manifest
+++ b/app-emulation/winetricks/Manifest
@@ -1,5 +1,7 @@
DIST winetricks-20200412.tar.gz 684548 BLAKE2B e29eba0c73ec0649523dac0f0efd145a5c9fe60d94ae98bc55ec430f511cc5bdf3149d87289973a85a373f2f91c3bd5521470853e06f5ec4af83fc810aa4fdc5 SHA512 d6ca5628b7d296b3168ef088ca0b03aff8b73da8a139061ca64fac0685ec29bf2b7e075b89226f8ce3af511947eac45d4c72cfb1199e6b72666fc67547b77588
+DIST winetricks-20201206.tar.gz 690966 BLAKE2B 8304d64657fdd921974f0c326bb4e0e1d859a69e573a7387c945c7dbfd20540621cc9c89718069b569309ac2358872083d651d29ddce616d1c2cf9a12ed39943 SHA512 6965bea9bc8bb212fe2b851a53dd144c52b37466cd0d6d6a933e4e0c16b202647f1b19804159642ce9fda566872ca51e8326e8716fafdea43cd09f24ed6b4a25
DIST winetricks-gentoo-2012.11.24.tar.bz2 6398 BLAKE2B 54a4502f6e8ef15d21b02c43e3ce599e32d476c2559246064de14cc4ce2243ff11dde681d24c8a7f4913c3d7a10b855bda47e8fb8ecad31e00d839705416be6f SHA512 59c93b73f3a7b2d11aefcde2ff66659ff1de21ad4b5f232f4b60572f3a48b15a6c49f369b1696862bf1b33fde190bf5598945e9536fb41ddec42d8def4d2be2a
EBUILD winetricks-20200412.ebuild 2051 BLAKE2B d37bffe1f2386eb52a2cd1697b7e9c8ea67807ac400fa4474b22e76a83aeeae04176215d9fa64845e1627723d9ba3c18c03c6b0e020e1db3a50fb04ce378e50b SHA512 bde6f11832da7d9efcbdf226ed7f37b9a2b7da1eb79001dc00ea398c5eadc41f0bc5821d19cbdbf9a1c4df80a395dc5cf718b2e51ad051a64141a41758eacc5e
-EBUILD winetricks-99999999.ebuild 2053 BLAKE2B 7397013ffbeafd1bf53b64d8980132a86cf48bada822049d75012753bd5a88e34a84b8d0e5909f99d5b63503683a0f85be4aa180279b529a00c2d9db8e7ecbde SHA512 d0c888efb8cc8a8a4976e1900741a6b7172280050805e3ee41f811694fdc363ba6563d149334cded5d8e950ff6af70987d3ea824dc8432498e41d6afea4278d9
+EBUILD winetricks-20201206.ebuild 1997 BLAKE2B fc9bd9fd39e90ed9786dcb37910a0f2150b012460f7feba37bafedcf7df7e78146e1de812a42314aa7a9c048f796f25cb1be470fb9201719dfbf6884d8a80d58 SHA512 0b132794ce98987a5da0a4167fd14c29866278ee949521509f1f981762f1306bf2f1dbb92d42c0354af89e28790c8f5bc6d78d467aba6b8bba15a49822fe878c
+EBUILD winetricks-99999999.ebuild 1997 BLAKE2B fc9bd9fd39e90ed9786dcb37910a0f2150b012460f7feba37bafedcf7df7e78146e1de812a42314aa7a9c048f796f25cb1be470fb9201719dfbf6884d8a80d58 SHA512 0b132794ce98987a5da0a4167fd14c29866278ee949521509f1f981762f1306bf2f1dbb92d42c0354af89e28790c8f5bc6d78d467aba6b8bba15a49822fe878c
MISC metadata.xml 713 BLAKE2B 7d9673350201c49de4651ecb8975ed21387259f3375c1b531b63b2a0e0e65f0b2540806db5f6d1d47953911ca36b0d06bf8edaa57ad5e546d242eebcd96f869f SHA512 2a4c5a6ecfc558f3c7382538b8701ab95c3d771a02c51f5dae852a0e90b7df51be65200b337bcc3c92ef9bf827c23954097b3b5e8c99004db729ed6d77e64cfc
diff --git a/app-emulation/winetricks/winetricks-20201206.ebuild b/app-emulation/winetricks/winetricks-20201206.ebuild
new file mode 100644
index 000000000000..89dcbb57c973
--- /dev/null
+++ b/app-emulation/winetricks/winetricks-20201206.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Winetricks/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/Winetricks/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+wtg="winetricks-gentoo-2012.11.24"
+
+SRC_URI="${SRC_URI}
+ gtk? ( https://dev.gentoo.org/~chiitoo/distfiles/${wtg}.tar.bz2 )
+ kde? ( https://dev.gentoo.org/~chiitoo/distfiles/${wtg}.tar.bz2 )
+"
+
+DESCRIPTION="Easy way to install DLLs needed to work around problems in Wine"
+HOMEPAGE="https://github.com/Winetricks/winetricks https://wiki.winehq.org/Winetricks"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="gtk kde rar test"
+RESTRICT="!test? ( test )"
+
+# dev-util/shellcheck is not available for x86
+RESTRICT+=" x86? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/bashate
+ dev-util/checkbashisms
+ || (
+ dev-util/shellcheck-bin
+ dev-util/shellcheck
+ )
+ )
+"
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unzip
+ net-misc/wget
+ virtual/wine
+ x11-misc/xdg-utils
+ gtk? ( gnome-extra/zenity )
+ kde? ( kde-apps/kdialog )
+ rar? ( app-arch/unrar )
+"
+
+# Test targets include syntax checks only, not the "heavy duty" tests
+# that would require a lot of disk space, as well as network access.
+
+# This uses a non-standard "Wine" category, which is provided by
+# '/etc/xdg/menus/applications-merged/wine.menu' from the
+# 'app-emulation/wine-desktop-common' package.
+# https://bugs.gentoo.org/451552
+QA_DESKTOP_FILE="usr/share/applications/winetricks.desktop"
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]]; then
+ git-r3_src_unpack
+
+ if use gtk || use kde; then
+ unpack ${wtg}.tar.bz2
+ fi
+
+ else
+ default
+ fi
+}
+
+src_test() {
+ ./tests/shell-checks || die "Test(s) failed."
+}
+
+src_install() {
+ default
+
+ if ! use gtk && ! use kde; then
+ rm -r "${ED}"/usr/share/applications || die
+ rm -r "${ED}"/usr/share/icons || die
+ fi
+}
diff --git a/app-emulation/winetricks/winetricks-99999999.ebuild b/app-emulation/winetricks/winetricks-99999999.ebuild
index 3b4cea7a0559..89dcbb57c973 100644
--- a/app-emulation/winetricks/winetricks-99999999.ebuild
+++ b/app-emulation/winetricks/winetricks-99999999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit desktop xdg
+inherit xdg
if [[ ${PV} == "99999999" ]] ; then
EGIT_REPO_URI="https://github.com/Winetricks/${PN}.git"
@@ -84,10 +84,8 @@ src_test() {
src_install() {
default
- if use gtk || use kde; then
- cd "${WORKDIR}/${wtg}" || die
- domenu winetricks.desktop
- insinto /usr/share/icons/hicolor/scalable/apps
- doins wine-winetricks.svg
+ if ! use gtk && ! use kde; then
+ rm -r "${ED}"/usr/share/applications || die
+ rm -r "${ED}"/usr/share/icons || die
fi
}