summaryrefslogtreecommitdiff
path: root/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-21 19:03:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-21 19:03:35 +0000
commit0ebf740b9c9bc7c10ac41bea315ecc6c01c79166 (patch)
tree15bb76d57cfb8652fd2627a24007e0bb92ec4a99 /app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
parent5b5df25227111ef465caf5c52bcfb66dac3219cd (diff)
gentoo resync : 21.01.2018
Diffstat (limited to 'app-emulation/wine-vanilla/wine-vanilla-9999.ebuild')
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild38
1 files changed, 28 insertions, 10 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index 4e3940a00299..d1fca61ea408 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -24,7 +24,7 @@ else
fi
S="${WORKDIR}/${MY_P}"
-GWP_V="20170830"
+GWP_V="20180119"
PATCHDIR="${WORKDIR}/gentoo-wine-patches"
DESCRIPTION="Free implementation of Windows(tm) on Unix, without external patchsets"
@@ -156,7 +156,8 @@ PATCHES=(
"${PATCHDIR}/patches/${MY_PN}-1.5.26-winegcc.patch" #260726
"${PATCHDIR}/patches/${MY_PN}-1.9.5-multilib-portage.patch" #395615
"${PATCHDIR}/patches/${MY_PN}-1.6-memset-O3.patch" #480508
- "${PATCHDIR}/patches/${MY_PN}-2.0-multislot-apploader.patch"
+ "${PATCHDIR}/patches/${MY_PN}-2.0-multislot-apploader.patch" #310611
+ "${PATCHDIR}/patches/${MY_PN}-2.0-prevent-build-of-localized-manpages.patch" #469418 #617864
)
PATCHES_BIN=()
@@ -335,6 +336,31 @@ src_prepare() {
cp "${PATCHDIR}/files/oic_winlogo.ico" dlls/user32/resources/ || die
l10n_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
+
+ # Fix manpage generation for locales #469418 and abi_x86_64 #617864
+ # Depends on wine-2.0-prevent-build-of-localized-manpages.patch"
+ # Duplicate manpages input for wine64
+ local man
+ for man in loader/*.man.in; do
+ cp ${man} ${man/wine/wine64} || die
+ done
+ # Add in proper manpages to Makefile
+ local search_text="wine.man.in"
+ if use abi_x86_64; then
+ sed -i "/${search_text}/i \
+ "$'\\\t'"wine64.man.in "$'\\\\' loader/Makefile.in || die
+ fi
+ local l
+ for l in de fr pl; do
+ if has ${l} ${LINGUAS-${l}}; then
+ sed -i "/${search_text}/i \
+ "$'\\\t'"wine.${l}.UTF-8.man.in "$'\\\\' loader/Makefile.in || die
+ if use abi_x86_64; then
+ sed -i "/${search_text}/i \
+ "$'\\\t'"wine64.${l}.UTF-8.man.in "$'\\\\' loader/Makefile.in || die
+ fi
+ fi
+ done
}
src_configure() {
@@ -479,14 +505,6 @@ multilib_src_install_all() {
for b in "${D%/}${MY_PREFIX}"/bin/*; do
make_wrapper "${b##*/}-${WINE_VARIANT}" "${MY_PREFIX}/bin/${b##*/}"
done
-
- # respect LINGUAS when installing man pages, #469418
- local l
- for l in de fr pl; do
- has ${l} ${LINGUAS-${l}} || rm -rf "${D%/}${MY_MANDIR}"/${l}*
- done
-
- eval "${glob_state}"
}
pkg_postinst() {