summaryrefslogtreecommitdiff
path: root/app-emulation/wine-staging
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-13 14:17:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-13 14:17:04 +0000
commitfb12f951d1a9071b4ddf774f2d570de245c2d061 (patch)
tree12b4074e61af9ee7b74753f5249f2362dd1060bf /app-emulation/wine-staging
parent4a74938e510c0dad732ae4c48f815dd0f0cabb46 (diff)
gentoo auto-resync : 13:02:2023 - 14:17:03
Diffstat (limited to 'app-emulation/wine-staging')
-rw-r--r--app-emulation/wine-staging/Manifest2
-rw-r--r--app-emulation/wine-staging/wine-staging-9999.ebuild22
2 files changed, 15 insertions, 9 deletions
diff --git a/app-emulation/wine-staging/Manifest b/app-emulation/wine-staging/Manifest
index 5ca9ac69d5ba..b55ee5947e3d 100644
--- a/app-emulation/wine-staging/Manifest
+++ b/app-emulation/wine-staging/Manifest
@@ -13,5 +13,5 @@ EBUILD wine-staging-7.19.ebuild 11179 BLAKE2B 58982c661d242e8e165d7b1d7083284eed
EBUILD wine-staging-7.22.ebuild 11281 BLAKE2B f8be09ce1670d897fcc72d92e816140be8507d92c70a2fe58fbd224e522a74749ef158173f54f09025488a0d5b1a572112410e9774eafc5f684cb8c1b567c9c5 SHA512 58acbe4ddf7045a991f156fb8d70c89fc83e8cb3733884154f263078671e02f6cdf961cdc953709e8da818ab92f8830a5a065acfd17b4f21316b004be0ca112c
EBUILD wine-staging-8.0.ebuild 11313 BLAKE2B 8e6e5eeee1e58aa9da6f0424bf588d89d90434369dbb17511dfd44498a159de206b984b8af884e26cbfc5dfbf331090887c505d0e0f7e2bed1dfb8dfa78a951b SHA512 1b5c5e9bf2c799c80652629d4108d9b11d018515e7fc4b336ca3281e15e0061a1c2316106d239872d5f77c2fe640e4e5b5be1f54f42f66f917c356b934ee7ce1
EBUILD wine-staging-8.1.ebuild 11286 BLAKE2B bc764057d81f5fa4924413e191a85684f0f730fcd95dad32c62d495351dec5432ab15c8b2e37af4b457bcb37e45272c5860c82762af33a5ce8eb3bc67aca6304 SHA512 f306d4563077d9fc8d919f757508619292fcc31613a73a7b22de4bf586cf39b17cad2fdafc5e99fee1b7b2e670e08480c6ad38dc153468e7937c5681ca6c7380
-EBUILD wine-staging-9999.ebuild 11286 BLAKE2B bc764057d81f5fa4924413e191a85684f0f730fcd95dad32c62d495351dec5432ab15c8b2e37af4b457bcb37e45272c5860c82762af33a5ce8eb3bc67aca6304 SHA512 f306d4563077d9fc8d919f757508619292fcc31613a73a7b22de4bf586cf39b17cad2fdafc5e99fee1b7b2e670e08480c6ad38dc153468e7937c5681ca6c7380
+EBUILD wine-staging-9999.ebuild 11332 BLAKE2B 93c1c1442ca1154c34447ffacdbf00ed7f1c549ece8b7bb253246e9fae5cda107b462bbd8eaac3e62aaaeb72ef63d985b74ab3815f026fc543ae1c807b7771ff SHA512 d27c9a1d9e68167b58b9c1bfaf2ab515d037b74eab2a4a6c008b31f1a9917332b7e8777a7f83e39b9f62a242932ee663e012c24c2b8ab4ed56dce26522b070d9
MISC metadata.xml 2301 BLAKE2B 9b65253f5a19d8aafc6c9ccd361a0b8cdd14a600ddd51bf163603c7400b2c39bf147f7fe671e3aba68ff8f8f2874eec0b64dd73afe4dabad3667cd23ca99aee0 SHA512 885f7c8e2239733193d16b32bb29a21285ff732092ae0c095056ee311bdf9b7135200a29ede5958d668acf9777640f139ffc5ffe43b1455356ce4bc897621401
diff --git a/app-emulation/wine-staging/wine-staging-9999.ebuild b/app-emulation/wine-staging/wine-staging-9999.ebuild
index 887f0e540454..d6afdde72ae8 100644
--- a/app-emulation/wine-staging/wine-staging-9999.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9999.ebuild
@@ -4,7 +4,9 @@
EAPI=8
MULTILIB_COMPAT=( abi_x86_{32,64} )
-inherit autotools flag-o-matic multilib multilib-build toolchain-funcs wrapper
+PYTHON_COMPAT=( python3_{9..11} )
+inherit autotools edo flag-o-matic multilib multilib-build
+inherit python-any-r1 toolchain-funcs wrapper
WINE_GECKO=2.47.3
WINE_MONO=7.4.0
@@ -110,7 +112,16 @@ DEPEND="
${WINE_COMMON_DEPEND}
sys-kernel/linux-headers
X? ( x11-base/xorg-proto )"
+# gitapply.sh prefers git but can fallback to patch+extras
BDEPEND="
+ ${PYTHON_DEPS}
+ || (
+ dev-vcs/git
+ (
+ sys-apps/gawk
+ sys-apps/util-linux
+ )
+ )
dev-lang/perl
sys-devel/binutils
sys-devel/bison
@@ -164,19 +175,14 @@ src_unpack() {
}
src_prepare() {
- local staging=(
- ./patchinstall.sh DESTDIR="${S}"
+ local patchinstallargs=(
--all
- --backend=eapply
--no-autoconf
-W winemenubuilder-Desktop_Icon_Path #652176
${MY_WINE_STAGING_CONF}
)
- # source patcher in a subshell so can use eapply as a backend
- ebegin "Running ${staging[*]}"
- ( cd ../${P}/patches && . "${staging[@]}" )
- eend ${?} || die "Failed to apply the patchset"
+ edo "${PYTHON}" ../${P}/staging/patchinstall.py "${patchinstallargs[@]}"
# sanity check, bumping these has a history of oversights
local geckomono=$(sed -En '/^#define (GECKO|MONO)_VER/{s/[^0-9.]//gp}' \