summaryrefslogtreecommitdiff
path: root/app-emulation/wine-staging/wine-staging-7.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /app-emulation/wine-staging/wine-staging-7.3.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'app-emulation/wine-staging/wine-staging-7.3.ebuild')
-rw-r--r--app-emulation/wine-staging/wine-staging-7.3.ebuild28
1 files changed, 15 insertions, 13 deletions
diff --git a/app-emulation/wine-staging/wine-staging-7.3.ebuild b/app-emulation/wine-staging/wine-staging-7.3.ebuild
index 5c6ad86fddc9..700f6788f5a7 100644
--- a/app-emulation/wine-staging/wine-staging-7.3.ebuild
+++ b/app-emulation/wine-staging/wine-staging-7.3.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
PLOCALES="ar ast bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru si sk sl sr_RS@cyrillic sr_RS@latin sv ta te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eapi7-ver estack eutils flag-o-matic gnome2-utils multilib multilib-minimal pax-utils plocale toolchain-funcs virtualx xdg-utils
+inherit autotools estack flag-o-matic multilib-minimal pax-utils plocale toolchain-funcs virtualx wrapper xdg-utils
MY_PN="${PN%%-*}"
MY_PV="${PV/_/-}"
MY_P="${MY_PN}-${MY_PV}"
@@ -61,6 +61,11 @@ REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
# or fail due to Xvfb's opengl limitations.
RESTRICT="test"
+BDEPEND="mingw? ( !!>=cross-i686-w64-mingw32/binutils-2.38 !!>=cross-x86_64-w64-mingw32/binutils-2.38 )
+ sys-devel/flex
+ virtual/yacc
+ virtual/pkgconfig"
+
COMMON_DEPEND="
X? (
x11-libs/libXcursor[${MULTILIB_USEDEP}]
@@ -114,7 +119,6 @@ COMMON_DEPEND="
RDEPEND="${COMMON_DEPEND}
app-emulation/wine-desktop-common
>app-eselect/eselect-wine-0.3
- !app-emulation/wine:0
dos? ( >=games-emulation/dosbox-0.74_p20160629 )
gecko? ( app-emulation/wine-gecko:2.47.2[abi_x86_32?,abi_x86_64?] )
mono? ( app-emulation/wine-mono:7.1.1 )
@@ -131,10 +135,8 @@ RDEPEND="${COMMON_DEPEND}
# tools/make_requests requires perl
DEPEND="${COMMON_DEPEND}
- sys-devel/flex
+ ${BDEPEND}
>=sys-kernel/linux-headers-2.6
- virtual/pkgconfig
- virtual/yacc
X? ( x11-base/xorg-proto )
staging? (
dev-lang/perl
@@ -275,8 +277,8 @@ pkg_pretend() {
# Verify OSS support
if use oss; then
if ! has_version ">=media-sound/oss-4"; then
- eerror "You cannot build wine with USE=oss without having support from a"
- eerror "FreeBSD kernel or >=media-sound/oss-4 (only available through external repos)"
+ eerror "You cannot build wine with USE=oss without having support from"
+ eerror ">=media-sound/oss-4 (only available through external repos)"
eerror
die
fi
@@ -544,12 +546,12 @@ multilib_src_install_all() {
find "${ED}" -name *.la -delete || die
if ! use perl ; then # winedump calls function_grep.pl, and winemaker is a perl script
- rm "${D%/}${MY_PREFIX}"/bin/{wine{dump,maker},function_grep.pl} \
- "${D%/}${MY_MANDIR}"/man1/wine{dump,maker}.1 || die
+ rm "${D%}${MY_PREFIX}"/bin/{wine{dump,maker},function_grep.pl} \
+ "${D%}${MY_MANDIR}"/man1/wine{dump,maker}.1 || die
fi
- use abi_x86_32 && pax-mark psmr "${D%/}${MY_PREFIX}"/bin/wine{,-preloader} #255055
- use abi_x86_64 && pax-mark psmr "${D%/}${MY_PREFIX}"/bin/wine64{,-preloader}
+ use abi_x86_32 && pax-mark psmr "${D%}${MY_PREFIX}"/bin/wine{,-preloader} #255055
+ use abi_x86_64 && pax-mark psmr "${D%}${MY_PREFIX}"/bin/wine64{,-preloader}
# Avoid double prefix from dosym and make_wrapper
MY_PREFIX=${MY_PREFIX#${EPREFIX}}
@@ -564,7 +566,7 @@ multilib_src_install_all() {
# Make wrappers for binaries for handling multiple variants
# Note: wrappers instead of symlinks because some are shell which use basename
local b
- for b in "${ED%/}${MY_PREFIX}"/bin/*; do
+ for b in "${ED%}${MY_PREFIX}"/bin/*; do
make_wrapper "${b##*/}-${WINE_VARIANT}" "${MY_PREFIX}/bin/${b##*/}"
done
eshopts_pop