summaryrefslogtreecommitdiff
path: root/app-emulation/wine-staging/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-12 15:32:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-12 15:32:09 +0000
commitd1edfd3a57afc1db57e14cc58d3f28eea8eefd64 (patch)
treed5315c32caabd5ea57f0557a1b17681a6e12a435 /app-emulation/wine-staging/files
parent983485e93d76602266889d23c963609073b75e51 (diff)
gentoo auto-resync : 12:11:2022 - 15:32:08
Diffstat (limited to 'app-emulation/wine-staging/files')
-rw-r--r--app-emulation/wine-staging/files/wine-staging-7.21-crossflags.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-emulation/wine-staging/files/wine-staging-7.21-crossflags.patch b/app-emulation/wine-staging/files/wine-staging-7.21-crossflags.patch
new file mode 100644
index 000000000000..bdf5aeefb5bf
--- /dev/null
+++ b/app-emulation/wine-staging/files/wine-staging-7.21-crossflags.patch
@@ -0,0 +1,29 @@
+Restore CROSSLDFLAGS and ensure tested flags are saved in
+{arch}_*FLAGS (e.g. -fno-strict-aliasing)
+
+quickfix, odds are this will be revamped upstream
+--- a/configure.ac
++++ b/configure.ac
+@@ -919,9 +919,9 @@
+ saved_CC=$CC
+ saved_CFLAGS=$CFLAGS
++ saved_LDFLAGS=$LDFLAGS
+
+ CFLAGS=${CROSSCFLAGS:-"-g -O2"}
++ LDFLAGS=${CROSSLDFLAGS:-}
+ AS_VAR_COPY([CC],[${wine_arch}_CC])
+- AS_VAR_COPY([${wine_arch}_CFLAGS],[CFLAGS])
+- AS_VAR_COPY([${wine_arch}_LDFLAGS],[LDFLAGS])
+ AS_VAR_SET([${wine_arch}_EXTRACFLAGS],["-D__WINE_PE_BUILD -Wall"])
+
+@@ -1052,6 +1052,10 @@
+ AS_VAR_APPEND([${wine_arch}_LDFLAGS],[" -Wl,--build-id"])])
+
++ AS_VAR_COPY([${wine_arch}_CFLAGS],[CFLAGS])
++ AS_VAR_COPY([${wine_arch}_LDFLAGS],[LDFLAGS])
++
+ CC=$saved_CC
+ CFLAGS=$saved_CFLAGS
++ LDFLAGS=$saved_LDFLAGS
+ done
+