summaryrefslogtreecommitdiff
path: root/app-emulation/wine-proton/wine-proton-7.0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-10 15:32:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-10 15:32:41 +0100
commit56e9cc62c11546e2c081f8dc14a9cc965f14787c (patch)
tree6dd5cbe22a937288e8c471e95a9f92bffb5d5707 /app-emulation/wine-proton/wine-proton-7.0.6.ebuild
parentd087665a0d6764fc223d2f88a04db01d76af9cc0 (diff)
gentoo auto-resync : 10:08:2023 - 15:32:40
Diffstat (limited to 'app-emulation/wine-proton/wine-proton-7.0.6.ebuild')
-rw-r--r--app-emulation/wine-proton/wine-proton-7.0.6.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/app-emulation/wine-proton/wine-proton-7.0.6.ebuild b/app-emulation/wine-proton/wine-proton-7.0.6.ebuild
index 086837096042..294e5c9aab65 100644
--- a/app-emulation/wine-proton/wine-proton-7.0.6.ebuild
+++ b/app-emulation/wine-proton/wine-proton-7.0.6.ebuild
@@ -5,8 +5,8 @@ EAPI=8
MULTILIB_COMPAT=( abi_x86_{32,64} )
PYTHON_COMPAT=( python3_{10..12} )
-inherit autotools flag-o-matic multilib multilib-build python-any-r1
-inherit readme.gentoo-r1 toolchain-funcs wrapper
+inherit autotools flag-o-matic multilib multilib-build prefix
+inherit python-any-r1 readme.gentoo-r1 toolchain-funcs wrapper
WINE_GECKO=2.47.3
WINE_MONO=7.4.0
@@ -158,6 +158,9 @@ src_prepare() {
# similarly to staging, append to `wine --version` for identification
sed -i "s/wine_build[^1]*1/& (Proton-${WINE_PV})/" configure.ac || die
+ # datadir is not where wine-mono is installed, so prefixy alternate paths
+ hprefixify -w /get_mono_path/ dlls/mscoree/metahost.c
+
# always update for patches (including user's wrt #432348)
eautoreconf
tools/make_requests || die # perl
@@ -263,7 +266,7 @@ src_configure() {
# disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
# crashes with -march=skylake >=wine-8.10, similar issues with
# znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
- append-cflags -mno-avx
+ use custom-cflags || append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'