summaryrefslogtreecommitdiff
path: root/app-emulation/wine-mono/wine-mono-9.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-23 23:59:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-23 23:59:27 +0100
commite3f21c8aff8a76afe3423721c437a088e9232840 (patch)
treefde2c1906a9787adec106c5d6b708cd60de02c60 /app-emulation/wine-mono/wine-mono-9.1.0.ebuild
parent1f00990debeffd0052c194989d0a02baac23eb96 (diff)
gentoo auto-resync : 23:04:2024 - 23:59:26
Diffstat (limited to 'app-emulation/wine-mono/wine-mono-9.1.0.ebuild')
-rw-r--r--app-emulation/wine-mono/wine-mono-9.1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-emulation/wine-mono/wine-mono-9.1.0.ebuild b/app-emulation/wine-mono/wine-mono-9.1.0.ebuild
new file mode 100644
index 000000000000..f756896e7c2e
--- /dev/null
+++ b/app-emulation/wine-mono/wine-mono-9.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Replacement for the .NET runtime and class libraries in Wine"
+HOMEPAGE="https://wiki.winehq.org/Mono"
+SRC_URI="
+ shared? ( https://github.com/madewokherd/wine-mono/releases/download/${P}/${P}-x86.tar.xz )
+ !shared? ( https://github.com/madewokherd/wine-mono/releases/download/${P}/${P}-x86.msi )"
+S="${WORKDIR}"
+
+LICENSE="BSD-2 GPL-2 LGPL-2.1 MIT MPL-1.1"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+shared"
+
+src_install() {
+ insinto /usr/share/wine/mono
+
+ if use shared; then
+ doins -r ${P}
+ else
+ doins "${DISTDIR}"/${P}-x86.msi
+ fi
+}