summaryrefslogtreecommitdiff
path: root/app-emulation/wine-mono/wine-mono-7.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-17 23:53:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-17 23:53:43 +0100
commit3a8423ee2874c2fd96358b28af08d38d83e9bdc0 (patch)
tree4cb2ff2a0a12a3c5013370cccd6697938b087225 /app-emulation/wine-mono/wine-mono-7.4.1.ebuild
parent6fe0a08604ce763398dcbeb5fc63d814110f0748 (diff)
gentoo auto-resync : 17:04:2023 - 23:53:43
Diffstat (limited to 'app-emulation/wine-mono/wine-mono-7.4.1.ebuild')
-rw-r--r--app-emulation/wine-mono/wine-mono-7.4.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-emulation/wine-mono/wine-mono-7.4.1.ebuild b/app-emulation/wine-mono/wine-mono-7.4.1.ebuild
new file mode 100644
index 000000000000..96896ce732cf
--- /dev/null
+++ b/app-emulation/wine-mono/wine-mono-7.4.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Replacement for the .NET runtime and class libraries in Wine"
+HOMEPAGE="https://wiki.winehq.org/Mono"
+SRC_URI="
+ shared? ( https://github.com/madewokherd/wine-mono/releases/download/${P}/${P}-x86.tar.xz )
+ !shared? ( https://github.com/madewokherd/wine-mono/releases/download/${P}/${P}-x86.msi )"
+S="${WORKDIR}"
+
+LICENSE="BSD-2 GPL-2 LGPL-2.1 MIT MPL-1.1"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+shared"
+
+src_install() {
+ insinto /usr/share/wine/mono
+
+ if use shared; then
+ doins -r ${P}
+ else
+ doins "${DISTDIR}"/${P}-x86.msi
+ fi
+}