summaryrefslogtreecommitdiff
path: root/app-emulation/vpcs/vpcs-0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-emulation/vpcs/vpcs-0.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-emulation/vpcs/vpcs-0.6.ebuild')
-rw-r--r--app-emulation/vpcs/vpcs-0.6.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-emulation/vpcs/vpcs-0.6.ebuild b/app-emulation/vpcs/vpcs-0.6.ebuild
new file mode 100644
index 000000000000..6187e32e943d
--- /dev/null
+++ b/app-emulation/vpcs/vpcs-0.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simulate up to 9 PCs in place of VMware boxes in a Dynamips network"
+HOMEPAGE="http://vpcs.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.tbz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${S}/src/"
+
+src_prepare() {
+ # move Makefile in place
+ cp Makefile.linux Makefile
+
+ # replace hardcoded CFLAGS with user set CFLAGS
+ # append -fno-strict-aliasing to CFLAGS to suppress QA issues from upstream
+ # add user $LDFLAGS in the front and remove -s that strips binary
+ sed -e "s/-D\$(CPUTYPE)/${CFLAGS} -fno-strict-aliasing/" \
+ -e "s/^LDFLAGS=/LDFLAGS=${LDFLAGS} /" \
+ -e "s/-s //" \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ #put binary in /usr/bin
+ dobin vpcs
+
+ doman ../man/vpcs.1
+}