summaryrefslogtreecommitdiff
path: root/app-emulation/vov/vov-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/vov/vov-2.0.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/vov/vov-2.0.0.ebuild')
-rw-r--r--app-emulation/vov/vov-2.0.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-emulation/vov/vov-2.0.0.ebuild b/app-emulation/vov/vov-2.0.0.ebuild
new file mode 100644
index 000000000000..17fe7ee6c79f
--- /dev/null
+++ b/app-emulation/vov/vov-2.0.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit flag-o-matic
+
+DESCRIPTION="A tool that emulates the behavior of a Von-Neumann machine"
+HOMEPAGE="http://home.gna.org/vov/"
+SRC_URI="http://download.gna.org/vov/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="debug gprof"
+
+RDEPEND=""
+DEPEND=">=sys-devel/flex-2.5.33-r3
+ >=sys-apps/sed-4.1.5"
+
+src_unpack()
+{
+ unpack ${A}
+
+ # do no install redundant documentation
+ cd "${S}"
+ sed -i 's/src scripts docs/src scripts/' "${S}/Makefile.in"
+}
+
+src_compile()
+{
+ local fp_support=""
+
+ if use gprof; then
+ filter-flags "-fomit-frame-pointer"
+ fp_support="--enable-frame-pointer"
+ fi
+
+ econf \
+ `use_enable gprof` \
+ `use_enable debug` \
+ ${fp_support} \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install()
+{
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS README NEWS
+ doman docs/vov.1
+}