summaryrefslogtreecommitdiff
path: root/app-emulation/vendor-reset
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /app-emulation/vendor-reset
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'app-emulation/vendor-reset')
-rw-r--r--app-emulation/vendor-reset/Manifest5
-rw-r--r--app-emulation/vendor-reset/files/modload.conf1
-rw-r--r--app-emulation/vendor-reset/metadata.xml11
-rw-r--r--app-emulation/vendor-reset/vendor-reset-0.1.0.ebuild46
-rw-r--r--app-emulation/vendor-reset/vendor-reset-9999.ebuild46
5 files changed, 109 insertions, 0 deletions
diff --git a/app-emulation/vendor-reset/Manifest b/app-emulation/vendor-reset/Manifest
new file mode 100644
index 000000000000..1c9f429a1f86
--- /dev/null
+++ b/app-emulation/vendor-reset/Manifest
@@ -0,0 +1,5 @@
+AUX modload.conf 13 BLAKE2B 1e774873c1bf09ca1f3ec2c006b1938e3aa07187dd5a7f926369d6d1bc2c21bfe52f2cbb632f64174485896c8691ac4cbd10e988b7db7a2a9ada7fdccda1a22d SHA512 7a4bf9c95af41bf11e5a720f6258d62822f553c6f349dbe93cf23743b851d830340d268954252d6f058ea2fa823006a63afd45875e7b9108d5d2a6a1a316ff6d
+DIST vendor-reset-0.1.0.tar.gz 12718324 BLAKE2B 762ec8bc289b572ab8f8ecc3fa233e3c78c48c48a261c58ce1be9c10356a55957e0bd8fd01e3143443be74236bf9ed540b84d332788c67aa949599ccc5a564d3 SHA512 ed4dcb1a71fa8901732e729d37b501ac105cc2c93d0666e44c08e311d99a244027339d5709a9305ff992ca2acb2f337793cdb1f9369197911985cd20d6f3139f
+EBUILD vendor-reset-0.1.0.ebuild 938 BLAKE2B b813812d660f5d8a8e3bf338df26b19c11e7a2c8f107a96ed2711a165309a9476c04b74fb196a620e77907e6bed52bedb02a40cbfbf1e01dc0e17556316ba270 SHA512 b87a8e5c4ff7ec4a6fb0629d898b51e82f55bf748c3fc6bb4897c20add7d0e6024195404b9973d601a7c8d6b45425367e0ffe0d5084377f968f0941f5751e0d3
+EBUILD vendor-reset-9999.ebuild 938 BLAKE2B b813812d660f5d8a8e3bf338df26b19c11e7a2c8f107a96ed2711a165309a9476c04b74fb196a620e77907e6bed52bedb02a40cbfbf1e01dc0e17556316ba270 SHA512 b87a8e5c4ff7ec4a6fb0629d898b51e82f55bf748c3fc6bb4897c20add7d0e6024195404b9973d601a7c8d6b45425367e0ffe0d5084377f968f0941f5751e0d3
+MISC metadata.xml 326 BLAKE2B eb99500232f3d17e81b626f037ab585c48b49eab4d14616296af7b2c35507265e7aad497b28c25f5e89b4fdb56d9ab3242e51641f87b6580e85944af25a0bc9c SHA512 bcb6dbff6d69f20509d440a3c1b9aa2d4d9d0206fc2daca744acf29e9fceb8458a4d58b70ad77654bfcaf1094cbc20da5b43318059a3dee30913cacde1918a69
diff --git a/app-emulation/vendor-reset/files/modload.conf b/app-emulation/vendor-reset/files/modload.conf
new file mode 100644
index 000000000000..ff75088aa8fe
--- /dev/null
+++ b/app-emulation/vendor-reset/files/modload.conf
@@ -0,0 +1 @@
+vendor-reset
diff --git a/app-emulation/vendor-reset/metadata.xml b/app-emulation/vendor-reset/metadata.xml
new file mode 100644
index 000000000000..95a133672a10
--- /dev/null
+++ b/app-emulation/vendor-reset/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sarnex@gentoo.org</email>
+ <name>Nick Sarnie</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gnif/vendor-reset</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emulation/vendor-reset/vendor-reset-0.1.0.ebuild b/app-emulation/vendor-reset/vendor-reset-0.1.0.ebuild
new file mode 100644
index 000000000000..c772c4558764
--- /dev/null
+++ b/app-emulation/vendor-reset/vendor-reset-0.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/gnif/vendor-reset.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/gnif/vendor-reset/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="Linux kernel vendor specific hardware reset module"
+HOMEPAGE="https://github.com/gnif/vendor-reset"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ local CONFIG_CHECK="FTRACE KPROBES PCI_QUIRKS KALLSYMS FUNCTION_TRACER"
+ linux-mod_pkg_setup
+}
+
+src_compile() {
+ set_arch_to_kernel
+ emake \
+ DESTDIR="${ED}" \
+ INSTALL_MOD_PATH="${ED}"
+}
+
+src_install() {
+ set_arch_to_kernel
+ emake \
+ DESTDIR="${ED}" \
+ INSTALL_MOD_PATH="${ED}" \
+ install
+
+ insinto /etc/modules-load.d/
+ newins "${FILESDIR}"/modload.conf vendor-reset.conf
+}
diff --git a/app-emulation/vendor-reset/vendor-reset-9999.ebuild b/app-emulation/vendor-reset/vendor-reset-9999.ebuild
new file mode 100644
index 000000000000..c772c4558764
--- /dev/null
+++ b/app-emulation/vendor-reset/vendor-reset-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/gnif/vendor-reset.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/gnif/vendor-reset/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="Linux kernel vendor specific hardware reset module"
+HOMEPAGE="https://github.com/gnif/vendor-reset"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ local CONFIG_CHECK="FTRACE KPROBES PCI_QUIRKS KALLSYMS FUNCTION_TRACER"
+ linux-mod_pkg_setup
+}
+
+src_compile() {
+ set_arch_to_kernel
+ emake \
+ DESTDIR="${ED}" \
+ INSTALL_MOD_PATH="${ED}"
+}
+
+src_install() {
+ set_arch_to_kernel
+ emake \
+ DESTDIR="${ED}" \
+ INSTALL_MOD_PATH="${ED}" \
+ install
+
+ insinto /etc/modules-load.d/
+ newins "${FILESDIR}"/modload.conf vendor-reset.conf
+}