summaryrefslogtreecommitdiff
path: root/app-emulation/runc/runc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-emulation/runc/runc-9999.ebuild
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/runc/runc-9999.ebuild')
-rw-r--r--app-emulation/runc/runc-9999.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/app-emulation/runc/runc-9999.ebuild b/app-emulation/runc/runc-9999.ebuild
deleted file mode 100644
index 8973c7491259..000000000000
--- a/app-emulation/runc/runc-9999.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils multilib
-
-DESCRIPTION="runc container cli tools"
-HOMEPAGE="http://runc.io"
-
-GITHUB_URI="github.com/opencontainers/runc"
-
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="git://${GITHUB_URI}.git"
- inherit git-r3
-else
- SRC_URI="https://${GITHUB_URI}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc64"
-fi
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="+seccomp"
-
-DEPEND=">=dev-lang/go-1.4:="
-RDEPEND="seccomp? ( sys-libs/libseccomp )
- !app-emulation/docker-runc"
-
-src_compile() {
- # Taken from app-emulation/docker-1.7.0-r1
- export CGO_CFLAGS="-I${ROOT}/usr/include"
- export CGO_LDFLAGS="-L${ROOT}/usr/$(get_libdir)"
-
- # Setup GOPATH so things build
- rm -rf .gopath
- mkdir -p .gopath/src/"$(dirname "${GITHUB_URI}")"
- ln -sf ../../../.. .gopath/src/"${GITHUB_URI}"
- export GOPATH="${PWD}/.gopath:${PWD}/vendor"
-
- # build up optional flags
- local options=( $(usex seccomp "seccomp") )
-
- emake BUILDTAGS="${options[@]}"
-}
-
-src_install() {
- dobin runc
-}