summaryrefslogtreecommitdiff
path: root/app-emulation/runc/runc-1.0.0_rc10-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /app-emulation/runc/runc-1.0.0_rc10-r1.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'app-emulation/runc/runc-1.0.0_rc10-r1.ebuild')
-rw-r--r--app-emulation/runc/runc-1.0.0_rc10-r1.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/app-emulation/runc/runc-1.0.0_rc10-r1.ebuild b/app-emulation/runc/runc-1.0.0_rc10-r1.ebuild
index 9f60bd86db13..0a433baafd1e 100644
--- a/app-emulation/runc/runc-1.0.0_rc10-r1.ebuild
+++ b/app-emulation/runc/runc-1.0.0_rc10-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -40,9 +40,9 @@ RESTRICT+=" test"
src_compile() {
# Taken from app-emulation/docker-1.7.0-r1
- export CGO_CFLAGS="-I${ROOT}/usr/include"
+ export CGO_CFLAGS="-I${ESYSROOT}/usr/include"
export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
- -L${ROOT}/usr/$(get_libdir)"
+ -L${ESYSROOT}/usr/$(get_libdir)"
# build up optional flags
local options=(
@@ -54,11 +54,8 @@ src_compile() {
)
myemakeargs=(
- BINDIR="${ED}/usr/bin"
BUILDTAGS="${options[*]}"
COMMIT=${RUNC_COMMIT}
- DESTDIR="${ED}"
- PREFIX="${ED}/usr"
GOPATH="${S}"
-C "src/${EGO_PN}"
)
@@ -67,6 +64,11 @@ src_compile() {
}
src_install() {
+ myemakeargs+=(
+ PREFIX="${ED}/usr"
+ BINDIR="${ED}/usr/bin"
+ MANDIR="${ED}/usr/share/man"
+ )
emake "${myemakeargs[@]}" install install-man install-bash
local DOCS=( src/"${EGO_PN}"/{README.md,PRINCIPLES.md,docs/.} )