summaryrefslogtreecommitdiff
path: root/app-emulation/ruffle/ruffle-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-20 07:15:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-20 07:15:41 +0100
commit7d1fc8f13082082c2539f20beadcf37089543b8e (patch)
treefda7c412f8ace82836e911da18f1b0f6eaf8bc55 /app-emulation/ruffle/ruffle-9999.ebuild
parentbc4457d8e0e53a2e43c4254d08053ba9708663e1 (diff)
gentoo auto-resync : 20:06:2023 - 07:15:40
Diffstat (limited to 'app-emulation/ruffle/ruffle-9999.ebuild')
-rw-r--r--app-emulation/ruffle/ruffle-9999.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/app-emulation/ruffle/ruffle-9999.ebuild b/app-emulation/ruffle/ruffle-9999.ebuild
index 3c6962772b54..e0410394da4a 100644
--- a/app-emulation/ruffle/ruffle-9999.ebuild
+++ b/app-emulation/ruffle/ruffle-9999.ebuild
@@ -9,7 +9,12 @@ DESCRIPTION="Flash Player emulator written in Rust"
HOMEPAGE="https://ruffle.rs/"
EGIT_REPO_URI="https://github.com/ruffle-rs/ruffle.git"
-LICENSE="Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD BSD-2 Boost-1.0 CC0-1.0 ISC MIT MPL-2.0 OFL-1.1 UbuntuFontLicense-1.0 Unicode-DFS-2016 ZLIB curl"
+LICENSE="|| ( MIT Apache-2.0 )"
+LICENSE+="
+ Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 BSD Boost-1.0
+ CC0-1.0 ISC UbuntuFontLicense-1.0 MIT MPL-2.0 OFL-1.1
+ Unicode-DFS-2016 ZLIB" # crates
+LICENSE+=" curl" # non-automated extra
SLOT="0"
# dlopen: libX* (see winit+x11-dl crates)
@@ -63,12 +68,12 @@ src_configure() {
# see .cargo/cargo.toml, only needed if RUSTFLAGS is set by the user
[[ -v RUSTFLAGS ]] && RUSTFLAGS+=" --cfg=web_sys_unstable_apis"
- if use test; then
- # tests will be skipped if don't build everything
- cargo_src_configure --workspace
- else
- cargo_src_configure --package={ruffle_{desktop,scanner},exporter}
- fi
+ local workspaces=(
+ ruffle_{desktop,scanner}
+ exporter
+ $(usev test tests)
+ )
+ cargo_src_configure ${workspaces[*]/#/--package=}
}
src_test() {