summaryrefslogtreecommitdiff
path: root/app-emulation/ruffle/ruffle-0_p20230724.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-28 04:35:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-28 04:35:59 +0100
commit2130804eda00268ce2a34eb936167bcfeb4281a0 (patch)
treeeea3135d689247ef9c9f3afafb362d0e26f9ed1d /app-emulation/ruffle/ruffle-0_p20230724.ebuild
parentebac931cc23ca55abe982e67b9a4f06f748d0bef (diff)
gentoo auto-resync : 28:07:2023 - 04:35:59
Diffstat (limited to 'app-emulation/ruffle/ruffle-0_p20230724.ebuild')
-rw-r--r--app-emulation/ruffle/ruffle-0_p20230724.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/app-emulation/ruffle/ruffle-0_p20230724.ebuild b/app-emulation/ruffle/ruffle-0_p20230724.ebuild
index e242da6b322b..012ed52e5f0f 100644
--- a/app-emulation/ruffle/ruffle-0_p20230724.ebuild
+++ b/app-emulation/ruffle/ruffle-0_p20230724.ebuild
@@ -615,7 +615,16 @@ src_configure() {
}
src_test() {
- virtx cargo_src_test
+ xdg_environment_reset
+
+ local skip=(
+ # this should be fine on real hardware, but currently fails with mesa's
+ # software rendering (bug #911320) -- note they are auto-skipped if
+ # USE=-gles2 on mesa, and this just forces to skip regardless
+ --skip visual/filters/displacement_map
+ )
+
+ virtx cargo_src_test -- "${skip[@]}"
}
src_install() {