summaryrefslogtreecommitdiff
path: root/app-emulation/rex-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/rex-client
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/rex-client')
-rw-r--r--app-emulation/rex-client/Manifest2
-rw-r--r--app-emulation/rex-client/metadata.xml5
-rw-r--r--app-emulation/rex-client/rex-client-9999.ebuild45
3 files changed, 52 insertions, 0 deletions
diff --git a/app-emulation/rex-client/Manifest b/app-emulation/rex-client/Manifest
new file mode 100644
index 000000000000..471e03f736f2
--- /dev/null
+++ b/app-emulation/rex-client/Manifest
@@ -0,0 +1,2 @@
+EBUILD rex-client-9999.ebuild 799 BLAKE2B fcaef591d7814eb8c1bd749c0c4360642b641a264a05e921d0c882b27142056af6400190e968e577918fe68a3ef83ffe973efba81a2c01c740eef5dc3217b8f2 SHA512 5fc207897713719ff42f9f0c77ad761566b3eefaaab9898f1f7e7c45480b1777f3219e48ada96363533fcee8805be25073d9f8720e0a056b92bf87bead9dbe57
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-emulation/rex-client/metadata.xml b/app-emulation/rex-client/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-emulation/rex-client/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>
diff --git a/app-emulation/rex-client/rex-client-9999.ebuild b/app-emulation/rex-client/rex-client-9999.ebuild
new file mode 100644
index 000000000000..4b6505b6105d
--- /dev/null
+++ b/app-emulation/rex-client/rex-client-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Remote EXexcution agent"
+HOMEPAGE="http://mduft.github.io/rex/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mduft/rex.git"
+else
+ SRC_URI=""
+ KEYWORDS="~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+REX_EXE=(
+ "client/rex-exec.sh"
+ "client/rex-register.sh"
+ "client/rex-paths.sh"
+ "client/rex-remote-pconv.sh"
+ "client/winpath2unix"
+ "client/unixpath2win"
+ )
+
+src_prepare() {
+ for x in ${REX_EXE[@]}; do
+ sed \
+ -e "s,\. \${HOME}/rex-config.sh,\. ${EPREFIX}/etc/rex.conf,g" \
+ -i "${x}" || die
+ done
+}
+
+src_install() {
+ for x in ${REX_EXE[@]}; do
+ dobin "${S}"/${x}
+ done
+
+ insinto /etc
+ newins client/rex-config.sh rex.conf
+}