summaryrefslogtreecommitdiff
path: root/app-emulation/protontricks/protontricks-1.10.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-26 02:47:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-26 02:47:53 +0100
commitc3a905eafd0ea87d50767fa3d24a6b565a41faa9 (patch)
tree8fcd60c2f36e3da5e4d545f47ddf14680f0d51e5 /app-emulation/protontricks/protontricks-1.10.5.ebuild
parent159ec3f090554ee5d7f61b2da553833fb7566f99 (diff)
gentoo auto-resync : 26:10:2023 - 02:47:53
Diffstat (limited to 'app-emulation/protontricks/protontricks-1.10.5.ebuild')
-rw-r--r--app-emulation/protontricks/protontricks-1.10.5.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-emulation/protontricks/protontricks-1.10.5.ebuild b/app-emulation/protontricks/protontricks-1.10.5.ebuild
new file mode 100644
index 000000000000..cbecf711b3cf
--- /dev/null
+++ b/app-emulation/protontricks/protontricks-1.10.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi xdg-utils
+
+DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+RDEPEND="app-emulation/winetricks
+ $(python_gen_cond_dep '
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/vdf[${PYTHON_USEDEP}]
+ ')
+ gui? ( gnome-extra/zenity
+ || (
+ app-emulation/winetricks[gtk]
+ app-emulation/winetricks[kde]
+ )
+ )"
+BDEPEND="$(python_gen_cond_dep '
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+')"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog
+
+ if ! use gui; then
+ ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
+ ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
+ ewarn
+ fi
+
+ elog "Protontricks can only find games for which a Proton prefix already exists."
+ elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
+ elog
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}