summaryrefslogtreecommitdiff
path: root/app-emulation/plus42/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-emulation/plus42/files
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-emulation/plus42/files')
-rw-r--r--app-emulation/plus42/files/plus42-1.0.4-fix-build-intel-lib.patch12
-rw-r--r--app-emulation/plus42/files/plus42-1.0.4-fix-makefile.patch38
2 files changed, 50 insertions, 0 deletions
diff --git a/app-emulation/plus42/files/plus42-1.0.4-fix-build-intel-lib.patch b/app-emulation/plus42/files/plus42-1.0.4-fix-build-intel-lib.patch
new file mode 100644
index 000000000000..e1e2ea89897a
--- /dev/null
+++ b/app-emulation/plus42/files/plus42-1.0.4-fix-build-intel-lib.patch
@@ -0,0 +1,12 @@
+diff -Naur free42-nologo-2.5.3.orig/gtk/build-intel-lib.sh free42-nologo-2.5.3/gtk/build-intel-lib.sh
+--- free42-nologo-2.5.3.orig/gtk/build-intel-lib.sh 2019-09-01 17:44:47.000000000 +0200
++++ free42-nologo-2.5.3/gtk/build-intel-lib.sh 2019-09-03 23:58:30.604579443 +0200
+@@ -65,7 +65,7 @@
+ esac
+
+ cd LIBRARY
+-$MK $OS_ARG CC=$CC CALL_BY_REF=1 GLOBAL_RND=1 GLOBAL_FLAGS=1 UNCHANGED_BINARY_FLAGS=0 $ENDIAN_ARG
++$MK $OS_ARG A=a CC=$CC CALL_BY_REF=1 GLOBAL_RND=1 GLOBAL_FLAGS=1 UNCHANGED_BINARY_FLAGS=0 $ENDIAN_ARG
+ mv libbid.a ../../gcc111libbid.a
+ cd ../..
+ ( echo '#ifdef FREE42_FPTEST'; echo 'const char *readtest_lines[] = {'; tr -d '\r' < IntelRDFPMathLib20U1/TESTS/readtest.in | sed 's/^\(.*\)$/"\1",/'; echo '0 };'; echo '#endif' ) > readtest_lines.cc
diff --git a/app-emulation/plus42/files/plus42-1.0.4-fix-makefile.patch b/app-emulation/plus42/files/plus42-1.0.4-fix-makefile.patch
new file mode 100644
index 000000000000..be7b40fbcd48
--- /dev/null
+++ b/app-emulation/plus42/files/plus42-1.0.4-fix-makefile.patch
@@ -0,0 +1,38 @@
+diff -Naur plus42-upstream-1.0.4.orig/gtk/Makefile plus42-upstream-1.0.4/gtk/Makefile
+--- plus42-upstream-1.0.4.orig/gtk/Makefile 2022-05-17 11:47:13.000000000 +0200
++++ plus42-upstream-1.0.4/gtk/Makefile 2022-05-22 21:41:34.492591806 +0200
+@@ -15,7 +15,7 @@
+ # along with this program; if not, see http://www.gnu.org/licenses/.
+ ###############################################################################
+
+-CFLAGS = -MMD \
++CFLAGS := -MMD \
+ -Wall \
+ -Wno-parentheses \
+ -Wno-write-strings \
+@@ -35,11 +35,13 @@
+ -DDECIMAL_GLOBAL_ROUNDING=1 \
+ -DDECIMAL_GLOBAL_ROUNDING_ACCESS_FUNCTIONS=1 \
+ -DDECIMAL_GLOBAL_EXCEPTION_FLAGS=1 \
+- -DDECIMAL_GLOBAL_EXCEPTION_FLAGS_ACCESS_FUNCTIONS=1
++ -DDECIMAL_GLOBAL_EXCEPTION_FLAGS_ACCESS_FUNCTIONS=1 \
++ ${CFLAGS}
+
+-CXXFLAGS = $(CFLAGS) \
++CXXFLAGS := $(CFLAGS) \
+ -fno-rtti \
+- -D_WCHAR_T_DEFINED
++ -D_WCHAR_T_DEFINED \
++ ${CXXFLAGS}
+
+ LIBS = gcc111libbid.a $(shell pkg-config --libs gtk+-3.0)
+
+@@ -118,7 +120,7 @@
+ ./keymap2cc
+
+ gcc111libbid.a:
+- sh ./build-intel-lib.sh
++ +sh ./build-intel-lib.sh
+ ln -s IntelRDFPMathLib20U1/TESTS/readtest.c
+
+ symlinks: