summaryrefslogtreecommitdiff
path: root/app-emulation/playonlinux/playonlinux-4.3.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /app-emulation/playonlinux/playonlinux-4.3.4.ebuild
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'app-emulation/playonlinux/playonlinux-4.3.4.ebuild')
-rw-r--r--app-emulation/playonlinux/playonlinux-4.3.4.ebuild106
1 files changed, 106 insertions, 0 deletions
diff --git a/app-emulation/playonlinux/playonlinux-4.3.4.ebuild b/app-emulation/playonlinux/playonlinux-4.3.4.ebuild
new file mode 100644
index 000000000000..f2a319b7bbeb
--- /dev/null
+++ b/app-emulation/playonlinux/playonlinux-4.3.4.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit desktop eutils python-single-r1 xdg
+
+MY_PN="PlayOnLinux"
+
+DESCRIPTION="Set of scripts to easily install and use Windows games and software"
+HOMEPAGE="https://playonlinux.com/"
+SRC_URI="https://www.playonlinux.com/script_files/${MY_PN}/${PV}/${MY_PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="winbind"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}
+ app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unzip
+ app-crypt/gnupg
+ app-misc/jq
+ dev-python/wxpython:3.0[${PYTHON_USEDEP}]
+ media-gfx/icoutils
+ || ( net-analyzer/netcat net-analyzer/openbsd-netcat )
+ net-misc/wget
+ virtual/imagemagick-tools
+ virtual/wine
+ winbind? ( net-fs/samba[winbind] )
+ x11-apps/mesa-progs
+ x11-terms/xterm
+"
+
+S="${WORKDIR}/${PN}"
+
+# TODO:
+# Having a real install script
+# It will let using LANGUAGES easily
+# How to deal with Microsoft Fonts installation asked every time ?
+# How to deal with wine version installed ? (have a better mgmt of system one)
+# Look at debian pkg: https://packages.debian.org/sid/playonlinux
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.2.4-pol-bash.patch"
+ "${FILESDIR}/${PN}-4.2.4-binary-plugin.patch"
+ "${FILESDIR}/${PN}-4.2.6-stop-update-warning.patch"
+)
+
+src_prepare() {
+ default
+
+ python_fix_shebang .
+
+ # remove playonmac
+ rm etc/{playonmac.icns,terminal.applescript} || die
+
+ # remove desktop integration
+ rm etc/{PlayOnLinux.desktop,PlayOnLinux.directory,playonlinux-Programs.menu} || die
+}
+
+src_install() {
+ # all things without exec permissions
+ insinto "/usr/share/${PN}"
+ doins -r resources lang lib etc plugins
+
+ # bash/ install
+ exeinto "/usr/share/${PN}/bash"
+ find "${S}/bash" -type f -exec doexe '{}' +
+ exeinto "/usr/share/${PN}/bash/expert"
+ find "${S}/bash/expert" -type f -exec doexe '{}' +
+
+ # python/ install
+ python_moduleinto "/usr/share/${PN}"
+ python_domodule python
+
+ # main executable files
+ exeinto "/usr/share/${PN}"
+ doexe ${PN}{,-pkg,-bash,-shell,-url_handler}
+
+ # icons
+ doicon -s 128 etc/${PN}.png
+ for size in 16 22 32; do
+ newicon -s $size etc/${PN}$size.png ${PN}.png
+ done
+
+ doman "${FILESDIR}"/playonlinux{,-pkg}.1
+ dodoc CHANGELOG.md
+
+ make_wrapper ${PN} "./${PN}" "/usr/share/${PN}"
+ make_wrapper ${PN}-pkg "./${PN}-pkg" "/usr/share/${PN}"
+ make_desktop_entry ${PN} ${MY_PN} ${PN} Game
+}
+
+pkg_prerm() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Installed software and games with playonlinux have not been removed."
+ elog "To remove them, you can re-install playonlinux and remove them using it,"
+ elog "or do it manually by removing .PlayOnLinux/ in your home directory."
+ fi
+}