summaryrefslogtreecommitdiff
path: root/app-emulation/phpvirtualbox/phpvirtualbox-5.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-25 08:09:37 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-25 08:09:37 +0000
commit693cc9b6e847a01c1bb692153021aaf9fb0fab25 (patch)
treebb2f7c299a4149f841c37a1208c7ac861aa95640 /app-emulation/phpvirtualbox/phpvirtualbox-5.2.1.ebuild
parent09351e78166b5e864197c4456ebae3f89dd0bed9 (diff)
gentoo resync : 25.01.2019
Diffstat (limited to 'app-emulation/phpvirtualbox/phpvirtualbox-5.2.1.ebuild')
-rw-r--r--app-emulation/phpvirtualbox/phpvirtualbox-5.2.1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-emulation/phpvirtualbox/phpvirtualbox-5.2.1.ebuild b/app-emulation/phpvirtualbox/phpvirtualbox-5.2.1.ebuild
new file mode 100644
index 000000000000..4738dfe6851e
--- /dev/null
+++ b/app-emulation/phpvirtualbox/phpvirtualbox-5.2.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eapi7-ver webapp readme.gentoo-r1
+
+MY_PV="$(ver_rs 2 '-')"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Web-based administration for VirtualBox in PHP"
+HOMEPAGE="https://sourceforge.net/projects/phpvirtualbox/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/php:*[gd,session,soap,unicode]
+ virtual/httpd-php:*
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+
+ local DISABLE_AUTOFORMATTING="true"
+ local DOC_CONTENTS=$(sed -e "s;@@FILESDIR@@;${FILESDIR};" \
+ -e "s;@@SLOT@@;${SLOT};" "${FILESDIR}/README.gentoo")
+
+ webapp_src_preinst
+
+ dodoc CHANGELOG.txt README.md
+ rm -f CHANGELOG.txt LICENSE.txt README.md
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config.php-example
+ webapp_serverowned "${MY_HTDOCSDIR}"/config.php-example
+
+ webapp_src_install
+ if has_version app-emulation/virtualbox[vboxwebsrv] || \
+ has_version app-emulation/virtualbox-bin[vboxwebsrv]
+ then
+ newinitd "${FILESDIR}"/vboxinit-initd vboxinit-${SLOT}
+ fi
+
+ readme.gentoo_create_doc
+
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+ readme.gentoo_print_elog
+}