summaryrefslogtreecommitdiff
path: root/app-emulation/libpod
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /app-emulation/libpod
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'app-emulation/libpod')
-rw-r--r--app-emulation/libpod/Manifest5
-rw-r--r--app-emulation/libpod/files/podman.initd17
-rw-r--r--app-emulation/libpod/files/podman.logrotated7
-rw-r--r--app-emulation/libpod/libpod-0.12.1.2.ebuild106
-rw-r--r--app-emulation/libpod/metadata.xml29
5 files changed, 164 insertions, 0 deletions
diff --git a/app-emulation/libpod/Manifest b/app-emulation/libpod/Manifest
new file mode 100644
index 000000000000..d843432f8871
--- /dev/null
+++ b/app-emulation/libpod/Manifest
@@ -0,0 +1,5 @@
+AUX podman.initd 566 BLAKE2B ccfedaea85b03a09446b678460d53591e62a9d8a1c205bd850fd95b4ce0ed47ebf767830fb9d30d32f1c0a4a1868eeb83c2c7deaef1617c0e6e91899807f0c36 SHA512 561c72d71827e523ab177b38961e38a594a14da8c6f0490d5743f35f4d02f4d813b43d9b3a66dd1aa72701c7d9a88ac6bb3a8435e72afcfa23289cce460bdb04
+AUX podman.logrotated 85 BLAKE2B 730899f93ee354e476629276b69224cfeaaa1603b6690cac3c0cd905cd75add19179f99e26f29edbd963d5f44c38a3a2db0b5a3613dc665ab801654eac13dc2e SHA512 0136d063b15b07c41a9370ba1845c4f368ec46a7a30683b7ff7cbb0b12e5b2711c9a45329f5102af6a969e562edcec006a8de9055e43e1caf9395847d0c5ec45
+DIST libpod-0.12.1.2.tar.gz 5987875 BLAKE2B 11381c53e768c94bfadcb2013a028f64058b0001cd985ef289d1618163225cdf10bd608cff0cd6f7fc1c094497184fc6d0cedea32fde54f3581ebb51eb5eabdd SHA512 9abb46d7880c4577d22b48aed01baeae29662dc3dbbdbc297f1eebe8324fb734d9bac6cd105dc93f7600753874c0fa581142d1b16f7490175cea80b8f62b34ce
+EBUILD libpod-0.12.1.2.ebuild 2661 BLAKE2B 8f020dea55baab9ee9af48f94c75b2e76de6fdc5ad8a60fbaf77ea432b77c3364a2183e97adf9e734d6df7d99845aa9308c0280e3187b32fe8671b75f47dce29 SHA512 d7e801c59fd1446fc319ac8c12b0fd5fad8dda0ab045d422606406b974076b838b8511b071051204b6fbd082ded69e0ba1d9bc7b059f98a1e27dc3a42be295e4
+MISC metadata.xml 878 BLAKE2B 2ec570f0e618c69c7e119a48e3dbb19bc9fc0baafa71e2ce09283ffa9a0a4d658e4f3c9ab7dbe6e618812d40cbed5d12d3a4d56227397611dac648cffb15ae20 SHA512 bc790e0f0287dc93a1dd0c5794c65064ccc03baeb3e6cd962d18b1cf071e01a4d25356c172f97dfe338423065b4a11434276c84c000daed87bb378f7d78d06ca
diff --git a/app-emulation/libpod/files/podman.initd b/app-emulation/libpod/files/podman.initd
new file mode 100644
index 000000000000..b590be16a1ba
--- /dev/null
+++ b/app-emulation/libpod/files/podman.initd
@@ -0,0 +1,17 @@
+#!/sbin/openrc-run
+# Copyright 2015-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+description="Podman Remote API Service"
+LOG_PATH="/var/log/${RC_SVCNAME}"
+RUN_PATH="/run/${RC_SVCNAME}"
+pidfile="${RUN_PATH}/${RC_SVCNAME}.pid"
+command="/usr/bin/podman"
+command_args="--log-level debug varlink -t 0 unix:/run/podman/io.podman"
+command_background="true"
+start_stop_daemon_args="--stdout ${LOG_PATH}/${RC_SVCNAME}.log --stderr ${LOG_PATH}/${RC_SVCNAME}.log"
+
+start() {
+ checkpath -d "${RUN_PATH}" "${LOG_PATH}"
+ default_start
+}
diff --git a/app-emulation/libpod/files/podman.logrotated b/app-emulation/libpod/files/podman.logrotated
new file mode 100644
index 000000000000..b9d723451b0a
--- /dev/null
+++ b/app-emulation/libpod/files/podman.logrotated
@@ -0,0 +1,7 @@
+/var/log/podman/podman.log {
+ missingok
+ size 5M
+ rotate 3
+ compress
+ copytruncate
+}
diff --git a/app-emulation/libpod/libpod-0.12.1.2.ebuild b/app-emulation/libpod/libpod-0.12.1.2.ebuild
new file mode 100644
index 000000000000..80dbb5f4f191
--- /dev/null
+++ b/app-emulation/libpod/libpod-0.12.1.2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_COMMIT="9551f6bb379d4af56dfb63ddf0f3682e40a6694e"
+EGO_PN="github.com/containers/${PN}"
+
+inherit golang-vcs-snapshot systemd
+
+DESCRIPTION="Library and podman tool for running OCI-based containers in Pods"
+HOMEPAGE="https://github.com/containers/libpod/"
+SRC_URI="https://github.com/containers/libpod/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+KEYWORDS="~amd64"
+IUSE="apparmor btrfs ostree selinux"
+REQUIRED_USE="!selinux? ( !ostree )"
+RESTRICT="test"
+
+COMMON_DEPEND="
+ app-crypt/gpgme:=
+ >=app-emulation/cri-o-1.13.0
+ app-emulation/runc
+ dev-libs/libassuan:=
+ dev-libs/libgpg-error:=
+ sys-fs/lvm2
+ sys-libs/libseccomp:=
+
+ apparmor? ( sys-libs/libapparmor )
+ btrfs? ( sys-fs/btrfs-progs )
+ ostree? (
+ dev-libs/glib:=
+ dev-util/ostree:=
+ )
+ selinux? ( sys-libs/libselinux:= )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-go/go-md2man"
+RDEPEND="${COMMON_DEPEND}"
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_prepare() {
+ default
+
+ # Disable installation of python modules here, since those are
+ # installed by separate ebuilds.
+ sed -e '/^GIT_.*/d' \
+ -e 's/$(GO) build/$(GO) build -v -work -x/' \
+ -e 's/^\(install:.*\) install\.python$/\1/' \
+ -i Makefile || die
+}
+
+src_compile() {
+ [[ -f hack/apparmor_tag.sh ]] || die
+ if use apparmor; then
+ echo -e "#!/bin/sh\necho apparmor" > hack/apparmor_tag.sh || die
+ else
+ echo -e "#!/bin/sh\ntrue" > hack/apparmor_tag.sh || die
+ fi
+
+ [[ -f hack/btrfs_installed_tag.sh ]] || die
+ if use btrfs; then
+ echo -e "#!/bin/sh\ntrue" > hack/btrfs_installed_tag.sh || die
+ else
+ echo -e "#!/bin/sh\necho exclude_graphdriver_btrfs" > \
+ hack/btrfs_installed_tag.sh || die
+ fi
+
+ [[ -f hack/ostree_tag.sh ]] || die
+ if use ostree; then
+ echo -e "#!/bin/sh\necho ostree" > hack/ostree_tag.sh || die
+ else
+ echo -e "#!/bin/sh\necho containers_image_ostree_stub" > hack/ostree_tag.sh || die
+ fi
+
+ [[ -f hack/selinux_tag.sh ]] || die
+ if use selinux; then
+ echo -e "#!/bin/sh\necho selinux" > hack/selinux_tag.sh || die
+ else
+ echo -e "#!/bin/sh\ntrue" > hack/selinux_tag.sh || die
+ fi
+
+ env -u LDFLAGS GOPATH="${WORKDIR}/${P}" GOBIN="${WORKDIR}/${P}/bin" \
+ emake all \
+ GIT_BRANCH=master \
+ GIT_BRANCH_CLEAN=master \
+ COMMIT_NO="${EGIT_COMMIT}" \
+ GIT_COMMIT="${EGIT_COMMIT}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${D}${EPREFIX}/usr" install
+
+ insinto /etc/containers
+ newins test/registries.conf registries.conf.example
+
+ newinitd "${FILESDIR}"/podman.initd podman
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/podman.logrotated" podman
+
+ keepdir /var/lib/containers
+}
diff --git a/app-emulation/libpod/metadata.xml b/app-emulation/libpod/metadata.xml
new file mode 100644
index 000000000000..1c5655b32d7b
--- /dev/null
+++ b/app-emulation/libpod/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <longdescription lang="en">
+ libpod provides a library for applications looking to use the
+ Container Pod concept popularized by Kubernetes. libpod also
+ contains a tool called podman for managing Pods, Containers,
+ and Container Images.
+ </longdescription>
+ <use>
+ <flag name="apparmor">
+ Enable AppArmor support.
+ </flag>
+ <flag name="btrfs">
+ Enables dependencies for the "btrfs" graph driver, including
+ necessary kernel flags.
+ </flag>
+ <flag name="ostree">
+ Enables dependencies for handling of OSTree images.
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="github">containers/libpod</remote-id>
+ </upstream>
+</pkgmetadata>