summaryrefslogtreecommitdiff
path: root/app-emulation/libguestfs/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /app-emulation/libguestfs/files
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'app-emulation/libguestfs/files')
-rw-r--r--app-emulation/libguestfs/files/1.36/0003-Fix-install-failure-when-not-built-with-OCaml-suppor.patch40
-rw-r--r--app-emulation/libguestfs/files/1.36/0004-Loosen-build-time-requirement-on-bash-completion.patch45
-rw-r--r--app-emulation/libguestfs/files/1.38/0001-Fix-install-failure-when-not-built-with-OCaml-suppor.patch40
-rw-r--r--app-emulation/libguestfs/files/1.38/0002-Loosen-build-time-requirement-on-bash-completion.patch45
4 files changed, 170 insertions, 0 deletions
diff --git a/app-emulation/libguestfs/files/1.36/0003-Fix-install-failure-when-not-built-with-OCaml-suppor.patch b/app-emulation/libguestfs/files/1.36/0003-Fix-install-failure-when-not-built-with-OCaml-suppor.patch
new file mode 100644
index 000000000000..093a53f11632
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.36/0003-Fix-install-failure-when-not-built-with-OCaml-suppor.patch
@@ -0,0 +1,40 @@
+From dc35ce2ba774a9284360bfd6532acb527a2f73d7 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Fri, 7 Dec 2018 11:21:25 +0100
+Subject: [PATCH 3/4] Fix install failure when not built with OCaml support
+
+Makefile rules in po/ require builder/index-parse.c to be generated to
+allow translation utilities to work on it, however builder/ is
+completely masked behind OCaml conditional build even if some tools do
+not require it and proper guards are in place already.
+
+Closes: https://bugzilla.redhat.com/show_bug.cgi?id=1614502
+---
+ Makefile.am | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 7eefacbeb..c0a68151f 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -155,7 +155,6 @@ if HAVE_OCAML
+ SUBDIRS += \
+ mllib \
+ customize \
+- builder builder/templates \
+ get-kernel \
+ resize \
+ sparsify \
+@@ -169,6 +168,9 @@ SUBDIRS += dib
+ endif
+ endif
+
++# Tools mixed with more OCAML based tools
++SUBDIRS += builder builder/templates
++
+ # Perl tools.
+ if HAVE_TOOLS
+ SUBDIRS += tools
+--
+2.19.2
+
diff --git a/app-emulation/libguestfs/files/1.36/0004-Loosen-build-time-requirement-on-bash-completion.patch b/app-emulation/libguestfs/files/1.36/0004-Loosen-build-time-requirement-on-bash-completion.patch
new file mode 100644
index 000000000000..9bce9b05b051
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.36/0004-Loosen-build-time-requirement-on-bash-completion.patch
@@ -0,0 +1,45 @@
+From 1f51b8ef921ad804022fc39b7465f9f731cbb6be Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Fri, 7 Dec 2018 12:14:15 +0100
+Subject: [PATCH 4/5] Loosen build time requirement on bash-completion
+
+Distributions might avoid pulling bash-completion during build as it is
+an optional feature and would only make sense at runtime anyway. Since
+this setting is well-known across a given distribution, allow them to
+provide the value and avoid the dependency.
+---
+ m4/guestfs_bash_completion.m4 | 21 ++++++++++-----------
+ 1 file changed, 10 insertions(+), 11 deletions(-)
+
+diff --git a/m4/guestfs_bash_completion.m4 b/m4/guestfs_bash_completion.m4
+index 1f171b79d..9e877f6ab 100644
+--- a/m4/guestfs_bash_completion.m4
++++ b/m4/guestfs_bash_completion.m4
+@@ -16,14 +16,13 @@
+ # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+ dnl Bash completion.
+-PKG_CHECK_MODULES([BASH_COMPLETION], [bash-completion >= 2.0], [
+- bash_completion=yes
+- AC_MSG_CHECKING([for bash-completions directory])
+- BASH_COMPLETIONS_DIR="`pkg-config --variable=completionsdir bash-completion`"
+- AC_MSG_RESULT([$BASH_COMPLETIONS_DIR])
+- AC_SUBST([BASH_COMPLETIONS_DIR])
+-],[
+- bash_completion=no
+- AC_MSG_WARN([bash-completion not installed])
+-])
+-AM_CONDITIONAL([HAVE_BASH_COMPLETION],[test "x$bash_completion" = "xyes"])
++AC_ARG_WITH([bashcompletiondir],
++ AS_HELP_STRING([--with-bashcompletiondir=DIR], [Bash completions directory]),
++ [],
++ [AS_IF([$($PKG_CONFIG --exists bash-completion)], [
++ with_bashcompletiondir=$($PKG_CONFIG --variable=completionsdir bash-completion)
++ ] , [
++ with_bashcompletiondir=${datadir}/bash-completion/completions
++ ])])
++AC_SUBST([BASH_COMPLETIONS_DIR], [$with_bashcompletiondir])
++AM_CONDITIONAL([HAVE_BASH_COMPLETION],[test -n "$with_bashcompletiondir"])
+--
+2.19.2
+
diff --git a/app-emulation/libguestfs/files/1.38/0001-Fix-install-failure-when-not-built-with-OCaml-suppor.patch b/app-emulation/libguestfs/files/1.38/0001-Fix-install-failure-when-not-built-with-OCaml-suppor.patch
new file mode 100644
index 000000000000..cb608beca08f
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.38/0001-Fix-install-failure-when-not-built-with-OCaml-suppor.patch
@@ -0,0 +1,40 @@
+From 3b06e1cbb25615495ef108d6ee194bb718e46408 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Fri, 7 Dec 2018 11:21:25 +0100
+Subject: [PATCH 1/2] Fix install failure when not built with OCaml support
+
+Makefile rules in po/ require builder/index-parse.c to be generated to
+allow translation utilities to work on it, however builder/ is
+completely masked behind OCaml conditional build even if some tools do
+not require it and proper guards are in place already.
+
+Closes: https://bugzilla.redhat.com/show_bug.cgi?id=1614502
+---
+ Makefile.am | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index cc363341f..5d96093a1 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -164,7 +164,6 @@ SUBDIRS += common/mlvisit
+ SUBDIRS += common/mlxml
+ SUBDIRS += common/mltools
+ SUBDIRS += customize
+-SUBDIRS += builder builder/templates
+ SUBDIRS += get-kernel
+ SUBDIRS += resize
+ SUBDIRS += sparsify
+@@ -178,6 +177,9 @@ SUBDIRS += dib
+ endif
+ endif
+
++# Tools mixed with more OCAML based tools
++SUBDIRS += builder builder/templates
++
+ # Perl tools.
+ if HAVE_TOOLS
+ SUBDIRS += tools
+--
+2.19.2
+
diff --git a/app-emulation/libguestfs/files/1.38/0002-Loosen-build-time-requirement-on-bash-completion.patch b/app-emulation/libguestfs/files/1.38/0002-Loosen-build-time-requirement-on-bash-completion.patch
new file mode 100644
index 000000000000..e68a4b0bded4
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.38/0002-Loosen-build-time-requirement-on-bash-completion.patch
@@ -0,0 +1,45 @@
+From b8a31fcfe81a680ffed1fa0879ac20a3e0e8753a Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Fri, 7 Dec 2018 12:14:15 +0100
+Subject: [PATCH 2/2] Loosen build time requirement on bash-completion
+
+Distributions might avoid pulling bash-completion during build as it is
+an optional feature and would only make sense at runtime anyway. Since
+this setting is well-known across a given distribution, allow them to
+provide the value and avoid the dependency.
+---
+ m4/guestfs-bash-completion.m4 | 21 ++++++++++-----------
+ 1 file changed, 10 insertions(+), 11 deletions(-)
+
+diff --git a/m4/guestfs-bash-completion.m4 b/m4/guestfs-bash-completion.m4
+index 1975b8c03..9a38ab2d6 100644
+--- a/m4/guestfs-bash-completion.m4
++++ b/m4/guestfs-bash-completion.m4
+@@ -16,14 +16,13 @@
+ # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+ dnl Bash completion.
+-PKG_CHECK_MODULES([BASH_COMPLETION], [bash-completion >= 2.0], [
+- bash_completion=yes
+- AC_MSG_CHECKING([for bash-completions directory])
+- BASH_COMPLETIONS_DIR="`pkg-config --variable=completionsdir bash-completion`"
+- AC_MSG_RESULT([$BASH_COMPLETIONS_DIR])
+- AC_SUBST([BASH_COMPLETIONS_DIR])
+-],[
+- bash_completion=no
+- AC_MSG_WARN([bash-completion not installed])
+-])
+-AM_CONDITIONAL([HAVE_BASH_COMPLETION],[test "x$bash_completion" = "xyes"])
++AC_ARG_WITH([bashcompletiondir],
++ AS_HELP_STRING([--with-bashcompletiondir=DIR], [Bash completions directory]),
++ [],
++ [AS_IF([$($PKG_CONFIG --exists bash-completion)], [
++ with_bashcompletiondir=$($PKG_CONFIG --variable=completionsdir bash-completion)
++ ] , [
++ with_bashcompletiondir=${datadir}/bash-completion/completions
++ ])])
++AC_SUBST([BASH_COMPLETIONS_DIR], [$with_bashcompletiondir])
++AM_CONDITIONAL([HAVE_BASH_COMPLETION],[test -n "$with_bashcompletiondir"])
+--
+2.19.2
+