summaryrefslogtreecommitdiff
path: root/app-emulation/img
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/img
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/img')
-rw-r--r--app-emulation/img/Manifest5
-rw-r--r--app-emulation/img/img-0.4.6.ebuild32
-rw-r--r--app-emulation/img/img-0.4.7.ebuild32
-rw-r--r--app-emulation/img/metadata.xml11
4 files changed, 80 insertions, 0 deletions
diff --git a/app-emulation/img/Manifest b/app-emulation/img/Manifest
new file mode 100644
index 000000000000..e75537b3c387
--- /dev/null
+++ b/app-emulation/img/Manifest
@@ -0,0 +1,5 @@
+DIST img-0.4.6.tar.gz 5635103 BLAKE2B 88e0ae3bdc0b9e1784d4d67635d119084a5e9dbe258b55da10f549b97f2d566f312226687bef0d28ad1ae3b13c764a44071bfe10ec0a189ad4bcf0bc8c83df5f SHA512 7f75d66237fe5ccf5923774e1d40ef04d9447f3e7de6641167679a1bf5b6305880a046e664fa7adb93dc4bd28e9f0e1ee790ecf2a225aa98b0202e47b8d01987
+DIST img-0.4.7.tar.gz 5642840 BLAKE2B 0cff71ad2e3ee7e7a21273bd7171a1cafb51b932a55981081bcd809f62c463e8a58d739ed5e7e46355a596650e272a90b848eb6c1818e948e6512cb07ac5fc5e SHA512 23e059537baedf20c17724f972db2fa2b81677bf7d62ce3f78cabde9984f10923f4fe56d3f02252f578b15e06112066c5ea7e6b41d61554bcafc618cca85d014
+EBUILD img-0.4.6.ebuild 921 BLAKE2B a0fc0c56c0bc10a929fa4932d1095f8d6e3f1af6bd65125eb85f8011fefdcc5e89aa12ba0755ea75b562cfe3f23c60d42ed1b7e094dddefc487ecd3e34baee71 SHA512 78ee9d32a0493d3d1bd8bd4611d81a25dfc69502a56e1b4ec5000d0f8c3356dd8f72569866ed74e75959834801a24536465316b34180905b693e5353a15c7cc9
+EBUILD img-0.4.7.ebuild 921 BLAKE2B 5993ad25c6e4aeec106c4919eae7748bafabb977151953c2f66944b282f70f327dd716916d4a4e6243463119ddef8c409d8837bcc04fa755215392a505087100 SHA512 e7a44443f989aade1b86db9fb7114b843cc3323b218fcd2f813354d8e79c7b21462d84cf3ee32b9269e82026bc51d59d0bf3f24eb80e97d778c598fd419cc9dd
+MISC metadata.xml 326 BLAKE2B bade1307a8d5bd0a9945fbb417b8506b7aaa4b66d5a502e18af1f7b008e325b5514e0fc018932396aba1116b5a3c11b12b89c43d925f7e97c8a75efcd9ef4f3d SHA512 a75050de970991e19edf7b7560ca46d27c959b9a91dcf87d40d31532c85c7af24ab29743d7295c731a3153774d33b03afa5c92470ca0c0c572d50c6ec65e5692
diff --git a/app-emulation/img/img-0.4.6.ebuild b/app-emulation/img/img-0.4.6.ebuild
new file mode 100644
index 000000000000..00b9e9fe0d17
--- /dev/null
+++ b/app-emulation/img/img-0.4.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/genuinetools/img"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="9c9f6f6fa351ddf9afd6a39cdb1a44ab290dd6a3"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Standalone daemon-less unprivileged Dockerfile and OCI container image builder"
+HOMEPAGE="https://github.com/genuinetools/img"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0"
+IUSE="seccomp"
+
+RESTRICT="test"
+
+src_compile() {
+ local TAGS=$(usex seccomp 'seccomp' '')
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build -tags "noembed ${TAGS}" -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/img . || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/README.md
+}
diff --git a/app-emulation/img/img-0.4.7.ebuild b/app-emulation/img/img-0.4.7.ebuild
new file mode 100644
index 000000000000..2b843d8ad2b3
--- /dev/null
+++ b/app-emulation/img/img-0.4.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/genuinetools/img"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="e76c25809631da79d0071966901675f9acb16edb"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Standalone daemon-less unprivileged Dockerfile and OCI container image builder"
+HOMEPAGE="https://github.com/genuinetools/img"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0"
+IUSE="seccomp"
+
+RESTRICT="test"
+
+src_compile() {
+ local TAGS=$(usex seccomp 'seccomp' '')
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build -tags "noembed ${TAGS}" -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/img . || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/README.md
+}
diff --git a/app-emulation/img/metadata.xml b/app-emulation/img/metadata.xml
new file mode 100644
index 000000000000..06bfaa067c93
--- /dev/null
+++ b/app-emulation/img/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel RĂ¼ger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">genuinetools/img</remote-id>
+ </upstream>
+</pkgmetadata>