summaryrefslogtreecommitdiff
path: root/app-emulation/img
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /app-emulation/img
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'app-emulation/img')
-rw-r--r--app-emulation/img/Manifest4
-rw-r--r--app-emulation/img/img-0.5.7-r1.ebuild34
-rw-r--r--app-emulation/img/img-0.5.7.ebuild31
-rw-r--r--app-emulation/img/metadata.xml9
4 files changed, 44 insertions, 34 deletions
diff --git a/app-emulation/img/Manifest b/app-emulation/img/Manifest
index 1a5afffa41e4..cac8678977d5 100644
--- a/app-emulation/img/Manifest
+++ b/app-emulation/img/Manifest
@@ -1,3 +1,3 @@
DIST img-0.5.7.tar.gz 3875988 BLAKE2B dd8f13f6861eadc3a4c3d2d07ac826e53a8f3b83d66974717e9312c579967e0c9b57657c8fe6e86f03bb91fd7a82bc6d8d7d87a70be4dd85da10800d8909a51d SHA512 a42247c2ceac0ccfcc2cfd6a561a058855869f0219994cd8fa2bdd5092be17803057e4cb48a2d5277fdfded74dd06eb7c3c3db590fbde91502aebcaf593ddef7
-EBUILD img-0.5.7.ebuild 901 BLAKE2B 4defdbd3caba5453bbda0a639a0bba14c7632a413de03d03203b51697d16ff259a229c39a58d0ca807a3fa5303445bed714696b470e4e44dac5b43aa9b66db93 SHA512 d9d45aa49a391d8816789bf2b8985c0d233bf6979acf9ead6b2dd45b26a82fb2358ff5e881ec5f3f8f4e9019b6699c7d623dffc59f17fa039708e8feac4698f1
-MISC metadata.xml 248 BLAKE2B 65f712fa82650530a08edb7671e6c6104649422106cd65d55253bdf920e84cc64ed47038feca9da18e770997c52cc6fdec416a6d82eb4146677b78d8509048ca SHA512 0de2cc5b3231aa87bc19df0801003e020b1599bf4a006a991a2d46d84495569245bb04756c1537376293765593167f2c083c46470389a5438ca7b44abafb0a2c
+EBUILD img-0.5.7-r1.ebuild 866 BLAKE2B 10d5041a3b379840b8675490a7abf54e5dc9c437e5d9424e4f3dab670fc5df138f1f768afb18391e2ee6ae966134f05ad5c956a917337b01f305e9aa93f7a946 SHA512 e5f07e98f8bced65cdecebc1a0b827c47ddeecbcf45963202638ac71b7b13a28ded8b3c2b31d19a87395f37e5a1cb406185d3d313959601c817052b836a3f6e1
+MISC metadata.xml 442 BLAKE2B 9eabfb5043d4b0c579254b497e4fe9252068eef479dc238307a1b69fb395491c7802d9792325f38876ef3ec280d7879a7a06dd1523635c9873565576b1a8edb7 SHA512 3f8d4c2c15806151513d588239dfd365fa1857fd8eb296e460fbc78d31aa2c3488b4da1cfeb32d91fa1a20bc957506954db632142d99b0382b1883d23f7cd492
diff --git a/app-emulation/img/img-0.5.7-r1.ebuild b/app-emulation/img/img-0.5.7-r1.ebuild
new file mode 100644
index 000000000000..4b2367c13e4e
--- /dev/null
+++ b/app-emulation/img/img-0.5.7-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_PN="github.com/genuinetools/img"
+
+inherit golang-vcs-snapshot
+
+DESCRIPTION="Standalone daemon-less unprivileged Dockerfile and OCI container image builder"
+HOMEPAGE="https://github.com/genuinetools/img"
+SRC_URI="https://github.com/genuinetools/img/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+LICENSE="MIT"
+SLOT="0"
+IUSE="seccomp"
+
+DEPEND="seccomp? ( sys-libs/libseccomp )"
+RDEPEND="${DEPEND}
+ app-emulation/runc"
+
+src_compile() {
+ GOPATH="${S}:$(get_golibdir_gopath)" \
+ GOCACHE="${T}/go-cache" \
+ IMG_DISABLE_EMBEDDED_RUNC=1 \
+ go build -v -work -x -tags "noembed $(usev seccomp)" \
+ -ldflags="-s -w -X ${EGO_PN}/version.VERSION=${PV}" "${EGO_PN}" || die
+}
+
+src_install() {
+ dobin img
+ dodoc "src/${EGO_PN}"/{README.md,AUTHORS}
+}
diff --git a/app-emulation/img/img-0.5.7.ebuild b/app-emulation/img/img-0.5.7.ebuild
deleted file mode 100644
index 21373b5f486d..000000000000
--- a/app-emulation/img/img-0.5.7.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit golang-build golang-vcs-snapshot
-
-EGO_PN="github.com/genuinetools/img"
-GIT_COMMIT="d14bb92b69804443263d647647b0833013b8df91"
-ARCHIVE_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64"
-
-DESCRIPTION="Standalone daemon-less unprivileged Dockerfile and OCI container image builder"
-HOMEPAGE="https://github.com/genuinetools/img"
-SRC_URI="${ARCHIVE_URI}"
-LICENSE="MIT"
-SLOT="0"
-IUSE="seccomp"
-
-RESTRICT="test"
-
-src_compile() {
- local TAGS=$(usex seccomp 'seccomp' '')
- pushd src/${EGO_PN} || die
- GOPATH="${S}" go build -mod vendor -tags "noembed ${TAGS}" -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/img . || die
- popd || die
-}
-
-src_install() {
- dobin bin/*
- dodoc -r src/${EGO_PN}/README.md
-}
diff --git a/app-emulation/img/metadata.xml b/app-emulation/img/metadata.xml
index 7213eb804f94..236a80be46df 100644
--- a/app-emulation/img/metadata.xml
+++ b/app-emulation/img/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>email@linxon.ru</email>
+ <name>Yury Martynov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="github">genuinetools/img</remote-id>
</upstream>