summaryrefslogtreecommitdiff
path: root/app-emulation/img
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:18:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:18:14 +0100
commit7b9f15840068dfaeea5684f8a1af1fe460dfa14c (patch)
tree112eea4497761c0227537330b58f9c7e0af3f9d8 /app-emulation/img
parent0bff53119f08d677db6c1a991bd30741682a8a08 (diff)
gentoo resync : 02.06.2018
Diffstat (limited to 'app-emulation/img')
-rw-r--r--app-emulation/img/Manifest5
-rw-r--r--app-emulation/img/img-0.3.9.ebuild32
-rw-r--r--app-emulation/img/img-0.4.2.ebuild32
-rw-r--r--app-emulation/img/metadata.xml11
4 files changed, 80 insertions, 0 deletions
diff --git a/app-emulation/img/Manifest b/app-emulation/img/Manifest
new file mode 100644
index 000000000000..0fbacac230af
--- /dev/null
+++ b/app-emulation/img/Manifest
@@ -0,0 +1,5 @@
+DIST img-0.3.9.tar.gz 6153717 BLAKE2B b561ed349c2b08f0e3448886b6c979d86fd6d4f47af0f03d7dd479a12f078b99f39e10d6a6b3ba9caffe2a9966102e3f3069fa6eacb70bb36f9842314e8a8e7b SHA512 23bf1e85cb9238742ffef44408bece52b5b0fefbeae9541a7740a4d798d1dc2c0f8efd02d8342842753925135dee843c4a7a20abe3a87ce1c475178461c9b8da
+DIST img-0.4.2.tar.gz 5622223 BLAKE2B 0a97a169111c359ec784c2f2a1acc5c67a2495003819403ba71d2462ee373f36540b03b6a581481e659fec51c84aaf17f9b0129481d060239e0d09c08777c646 SHA512 c9bd8cdfbc18515d64cbd36a3b9259381f582eff02c22a437960f098c139c9be784d4fcc225f66540e4c243b05e568250dc5fd3c1fdb09cbbcb9227db18e47c6
+EBUILD img-0.3.9.ebuild 911 BLAKE2B 556f2aacaabc9fd4c32e887c46a05e9759a405877fefd40294002fb2136d32329b62302abe1f7994f2112ab81b3bdffdbfceddc478b4bee3771eb5068be826fc SHA512 7a038c3c6f1742fa2f765310e5c0547d0d970b9db3fd7fc38e771fa6e016dfd2bd273cb5ff8e858e63b4daeb776cf4b2f594cd7e61da493b54c4a550f60e784b
+EBUILD img-0.4.2.ebuild 921 BLAKE2B daae503157d627655995772d9cb4dccd96930b34415710d8e7186412913d7c2b30bf7b683360fb4c557af57a7d6cefbe725aa22f1d04a7b3eecad18a3128b44e SHA512 e6f84116dc5bcb70328dfe594212f9ba43a9d08f9148072078201e8d943a0931d49801b68404369884342a909351168c6b69fc60aea6c37ac52d74356fcbec4c
+MISC metadata.xml 326 BLAKE2B bade1307a8d5bd0a9945fbb417b8506b7aaa4b66d5a502e18af1f7b008e325b5514e0fc018932396aba1116b5a3c11b12b89c43d925f7e97c8a75efcd9ef4f3d SHA512 a75050de970991e19edf7b7560ca46d27c959b9a91dcf87d40d31532c85c7af24ab29743d7295c731a3153774d33b03afa5c92470ca0c0c572d50c6ec65e5692
diff --git a/app-emulation/img/img-0.3.9.ebuild b/app-emulation/img/img-0.3.9.ebuild
new file mode 100644
index 000000000000..661f99352151
--- /dev/null
+++ b/app-emulation/img/img-0.3.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/genuinetools/img"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="e4a43d044778e3df56e0de3c6ca00706fcca8b50"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Standalone daemon-less unprivileged Dockerfile and OCI container image builder"
+HOMEPAGE="https://github.com/genuinetools/img"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0"
+IUSE="seccomp"
+
+RESTRICT="test"
+
+src_compile() {
+ local TAGS=$(usex seccomp 'seccomp' '')
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build -tags ${TAGS} -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/img . || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/README.md
+}
diff --git a/app-emulation/img/img-0.4.2.ebuild b/app-emulation/img/img-0.4.2.ebuild
new file mode 100644
index 000000000000..f0841cd49afb
--- /dev/null
+++ b/app-emulation/img/img-0.4.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/genuinetools/img"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="83e14d354393b360a4b21d6bb57510d17ffefa9e"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Standalone daemon-less unprivileged Dockerfile and OCI container image builder"
+HOMEPAGE="https://github.com/genuinetools/img"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0"
+IUSE="seccomp"
+
+RESTRICT="test"
+
+src_compile() {
+ local TAGS=$(usex seccomp 'seccomp' '')
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build -tags "noembed ${TAGS}" -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/img . || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/README.md
+}
diff --git a/app-emulation/img/metadata.xml b/app-emulation/img/metadata.xml
new file mode 100644
index 000000000000..06bfaa067c93
--- /dev/null
+++ b/app-emulation/img/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel RĂ¼ger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">genuinetools/img</remote-id>
+ </upstream>
+</pkgmetadata>