summaryrefslogtreecommitdiff
path: root/app-emulation/hyperd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/hyperd
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/hyperd')
-rw-r--r--app-emulation/hyperd/Manifest3
-rw-r--r--app-emulation/hyperd/hyperd-0.7.0-r1.ebuild50
-rw-r--r--app-emulation/hyperd/metadata.xml12
3 files changed, 65 insertions, 0 deletions
diff --git a/app-emulation/hyperd/Manifest b/app-emulation/hyperd/Manifest
new file mode 100644
index 000000000000..131d0b631348
--- /dev/null
+++ b/app-emulation/hyperd/Manifest
@@ -0,0 +1,3 @@
+DIST hyperd-0.7.0.tar.gz 10885921 BLAKE2B df139cee488cae017a4d0d0b58256d4201564c280fa727cbe5b30cee18565b9a942f8f0a377772fdd27046e84e93675168668116c43eb8932d51bbc264a86cd4 SHA512 7fc731b393a6bdf173101ee0a6d0e5a3339c6bb6dc1595fbde5b36df5a674f22e95f599e704925532ca0ee5ca931ebdf9f14bba9ad20b62000aee48408adb73f
+EBUILD hyperd-0.7.0-r1.ebuild 1110 BLAKE2B e2cdef75f0d2532c0d85a1a64fa3c89b54af3e1110729467809e5e3f1ca1178bf19f410e21020be14c787fe8b129652159bd3684abf46ffbfd9a05a0ae332d93 SHA512 acdf45032156d74c79420741ec66c960ebbfd33110214acc18d7859c0c66d3c7e3a33956bf446c495ce4abcb393e303d5f51780252fb820c22fc2679e2a808b8
+MISC metadata.xml 390 BLAKE2B 98cadf5a24f9474843545a2fd82ff0af679f12cae85e6269b65f3ddcaff606124479fa48440a1a48950e6ba794a2eb5423562583077b773ee32e8594b7fe4d85 SHA512 2d0f17843a3021453bcbc11838c4c3bbc97b642e507ff066dc4f18f507b29dd5a3ffabe373309c3b493399ec02f38d9c683d8f118c49fa8ea18e2e6f2bcede1b
diff --git a/app-emulation/hyperd/hyperd-0.7.0-r1.ebuild b/app-emulation/hyperd/hyperd-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..60e350cd094e
--- /dev/null
+++ b/app-emulation/hyperd/hyperd-0.7.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/hyperhq/hyperd"
+
+inherit autotools systemd golang-vcs-snapshot
+
+DESCRIPTION="Hypervisor-based Runtime for OCI"
+HOMEPAGE="https://github.com/hyperhq/hyperd"
+SRC_URI="https://github.com/hyperhq/hyperd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libvirt xen"
+
+RDEPEND="libvirt? ( >=app-emulation/libvirt-1.2.2 )
+ xen? ( app-emulation/xen )"
+DEPEND="${RDEPEND}
+ sys-fs/lvm2"
+
+src_prepare() {
+ pushd src/${EGO_PN} || die
+ default
+ eautoreconf
+ popd
+}
+
+src_configure() {
+ local myeconfargs=( $(use_with libvirt)
+ $(use_with xen) )
+ pushd src/${EGO_PN} || die
+ econf "${myeconfargs[@]}"
+ popd
+}
+
+src_compile() {
+ GOPATH="${S}:$(get_golibdir_gopath)" emake -C src/${EGO_PN}
+}
+
+src_install() {
+ dodoc src/${EGO_PN}/README.md
+ dobin src/${EGO_PN}/hyperd
+ dobin src/${EGO_PN}/hyperctl
+ insinto /etc/hyper/
+ doins src/${EGO_PN}/package/dist/etc/hyper/config
+ systemd_dounit src/${EGO_PN}/package/dist/lib/systemd/system/hyperd.service
+}
diff --git a/app-emulation/hyperd/metadata.xml b/app-emulation/hyperd/metadata.xml
new file mode 100644
index 000000000000..2babf919ffdd
--- /dev/null
+++ b/app-emulation/hyperd/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <use>
+ <flag name="libvirt">Enable support for KVM via libvirt</flag>
+ <flag name="xen">Enable support for the Xen Hypervisor</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">hyperhq/hyperd</remote-id>
+ </upstream>
+</pkgmetadata>