summaryrefslogtreecommitdiff
path: root/app-emulation/glean/glean-1.23.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-12 06:46:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-12 06:46:08 +0000
commitc6e62298405d39e635c0d8dd6e026c8cb667a478 (patch)
tree797bd877e6cc2cdcfe3e39ecfedf34781075fc86 /app-emulation/glean/glean-1.23.0-r1.ebuild
parent2c3b9bbdb114cc13b6ef8e0e5933c9e374fca8b6 (diff)
gentoo auto-resync : 12:03:2024 - 06:46:08
Diffstat (limited to 'app-emulation/glean/glean-1.23.0-r1.ebuild')
-rw-r--r--app-emulation/glean/glean-1.23.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emulation/glean/glean-1.23.0-r1.ebuild b/app-emulation/glean/glean-1.23.0-r1.ebuild
new file mode 100644
index 000000000000..ab8799b85a34
--- /dev/null
+++ b/app-emulation/glean/glean-1.23.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9,10,11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple program to write static config from config-drive"
+HOMEPAGE="https://opendev.org/opendev/glean"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/pbr[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}