summaryrefslogtreecommitdiff
path: root/app-emulation/docker-proxy/docker-proxy-0.8.0_p20201211.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /app-emulation/docker-proxy/docker-proxy-0.8.0_p20201211.ebuild
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'app-emulation/docker-proxy/docker-proxy-0.8.0_p20201211.ebuild')
-rw-r--r--app-emulation/docker-proxy/docker-proxy-0.8.0_p20201211.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-emulation/docker-proxy/docker-proxy-0.8.0_p20201211.ebuild b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20201211.ebuild
new file mode 100644
index 000000000000..f38858c48aee
--- /dev/null
+++ b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20201211.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+EGO_PN="github.com/docker/libnetwork"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ EGIT_COMMIT=5c6a95bfb20c61571a00f913c6b91959ede84e8d
+ SRC_URI="https://github.com/docker/libnetwork/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="Docker container networking"
+HOMEPAGE="https://github.com/docker/libnetwork"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+# needs dockerd
+RESTRICT="strip test"
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}" go build -o "bin/docker-proxy" ./cmd/proxy || die
+}
+
+src_install() {
+ dodoc README.md CHANGELOG.md
+ dobin bin/docker-proxy
+}