summaryrefslogtreecommitdiff
path: root/app-emulation/docker-compose/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /app-emulation/docker-compose/files
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'app-emulation/docker-compose/files')
-rw-r--r--app-emulation/docker-compose/files/docker-compose-1.22.0-setup-py.patch58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/files/docker-compose-1.22.0-setup-py.patch b/app-emulation/docker-compose/files/docker-compose-1.22.0-setup-py.patch
new file mode 100644
index 000000000000..191e96d63961
--- /dev/null
+++ b/app-emulation/docker-compose/files/docker-compose-1.22.0-setup-py.patch
@@ -0,0 +1,58 @@
+From 950506efebe97cb76f6cd3a558bab724452a51e9 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Mon, 24 Sep 2018 17:35:22 +0200
+Subject: [PATCH] setup.py: Drop generic upper version boundaries
+
+---
+ setup.py | 24 +++++++++++++-------------
+ 1 file changed, 13 insertions(+), 13 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index e0a26b0..1f9fb7f 100644
+--- a/setup.py
++++ b/setup.py
+@@ -30,16 +30,16 @@ def find_version(*file_paths):
+
+
+ install_requires = [
+- 'cached-property >= 1.2.0, < 2',
+- 'docopt >= 0.6.1, < 0.7',
+- 'PyYAML >= 3.10, < 4',
+- 'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0, < 2.19',
+- 'texttable >= 0.9.0, < 0.10',
+- 'websocket-client >= 0.32.0, < 1.0',
+- 'docker >= 3.4.1, < 4.0',
+- 'dockerpty >= 0.4.1, < 0.5',
+- 'six >= 1.3.0, < 2',
+- 'jsonschema >= 2.5.1, < 3',
++ 'cached-property >= 1.2.0',
++ 'docopt >= 0.6.1',
++ 'PyYAML >= 3.10',
++ 'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0',
++ 'texttable >= 0.9.0',
++ 'websocket-client >= 0.32.0',
++ 'docker >= 3.4.1',
++ 'dockerpty >= 0.4.1',
++ 'six >= 1.3.0',
++ 'jsonschema >= 2.5.1',
+ ]
+
+
+@@ -52,11 +52,11 @@ if sys.version_info[:2] < (3, 4):
+ tests_require.append('mock >= 1.0.1')
+
+ extras_require = {
+- ':python_version < "3.4"': ['enum34 >= 1.0.4, < 2'],
++ ':python_version < "3.4"': ['enum34 >= 1.0.4'],
+ ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5'],
+ ':python_version < "3.3"': ['ipaddress >= 1.0.16'],
+- ':sys_platform == "win32"': ['colorama >= 0.3.9, < 0.4'],
+- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'],
++ ':sys_platform == "win32"': ['colorama >= 0.3.9'],
++ 'socks': ['PySocks >= 1.5.6, != 1.5.7'],
+ }
+
+
+--
+2.19.0.rc2
+