summaryrefslogtreecommitdiff
path: root/app-emulation/containerd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /app-emulation/containerd
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'app-emulation/containerd')
-rw-r--r--app-emulation/containerd/Manifest2
-rw-r--r--app-emulation/containerd/containerd-1.3.9.ebuild84
2 files changed, 86 insertions, 0 deletions
diff --git a/app-emulation/containerd/Manifest b/app-emulation/containerd/Manifest
index e089edc0b297..99e79795bfdf 100644
--- a/app-emulation/containerd/Manifest
+++ b/app-emulation/containerd/Manifest
@@ -1,4 +1,6 @@
AUX containerd.initd 766 BLAKE2B 07b323c35f9cafa156969644ccab7c618baf60a82ad8037538ae23562c5663742a7453e00412eeafa72129a4806f3610f3f77865c7ebf3e58223a7286c9f712e SHA512 b70abb44d6bc0cdd8115104ef1fbb5099a270c29040351ceff738b9b6ff796a802f92dbbe2c49e04ae058043546bbe6a854e25044f5c07bea7bf6b6fc4f66018
DIST containerd-1.3.7.tar.gz 5709989 BLAKE2B 0cfa6f5bcd41c1591e64f41dbba2720bed5f25d61625b6d09be19df56fe74b61532b627c35a830e1e4937333f790f7ff8a5fad18b8869a679a6fec18daf238d3 SHA512 7c6de27b6529e3fb3f924ec67a260a51bc45186d69baa4cae6720a08e5c3b74aeb43d236c0a4739f297b2863233bde7d2246a597c9e17713c48bec767c6bbfee
+DIST containerd-1.3.9.tar.gz 5717856 BLAKE2B f6b9741f7d793a18b44813453d185cb9e8f4742fbb2987521445104fb44bca913571d6b4f6386ea048084d6565d41759c6ec95ac4591bd9b2101b40bbaafd8fa SHA512 79e0baab72169f84b8661b77f54d0a906a380cd00cbabd00bfec6c10d71a13fc4dd81c7b5e1c3ce184f91d3f68d6df9b735f13e6e04d494792bf7374058d43aa
EBUILD containerd-1.3.7.ebuild 1974 BLAKE2B 40e9d21e8bfc04de4931748ce962897a62353faaaf400b1f66ac625b24cd1f0aa8ed74ed808b3c5e97ebc0f4649126f9b9d806974a1103772f91537e89ec03f5 SHA512 6fe127a926c668b3c47ab90b82f56335125084dacfc75bc75a7af3d63adb8b7ade4fa5baaf437a80ef55f3383834e25d320106ca02ca3af106fbfdf92c54e8fe
+EBUILD containerd-1.3.9.ebuild 1941 BLAKE2B 4902047b9a87daf7aa960d4472fb7c0483515a8aea5cdba86970a408dd43b805cc0ca7cf69d45fea51fa47dfe5a4157016145293a083750d35af411db10e7fea SHA512 8bcecd9396a51ba28eb4a1008362e05f6bce203edeb97ab4b52f89f22bc5be67e8bbe05c8a27a330048feaab616c9660cdc91982d5de5bf90c2c56d27fdc976d
MISC metadata.xml 1175 BLAKE2B ee2c3165391688c6e20b0ecb35ccb59a5b621624b0dbfe72d8311ea3d0c1fc17894870f4be00282c9e50c7f931889b8d5f9667fd925eba98756f7b4fbf98cd20 SHA512 68dcef07630bd32f06360c0afd5742a7e3ad75645cfa77ef56a6d0236634ed0c8e69b517c53114d95fab5dbc6cae37f306d3328289b1e562a0a335a36596d19e
diff --git a/app-emulation/containerd/containerd-1.3.9.ebuild b/app-emulation/containerd/containerd-1.3.9.ebuild
new file mode 100644
index 000000000000..7c664edf94cd
--- /dev/null
+++ b/app-emulation/containerd/containerd-1.3.9.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# update on bump, look for https://github.com/docker\
+# docker-ce/blob/<docker ver OR branch>/components/engine/hack/dockerfile/install/containerd.installer
+CONTAINERD_COMMIT="ea765ab"
+EGO_PN="github.com/containerd/${PN}"
+
+inherit golang-vcs-snapshot toolchain-funcs
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.io/"
+SRC_URI="https://github.com/containerd/${PN}/archive/${CONTAINERD_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ppc64 ~x86"
+IUSE="apparmor btrfs device-mapper +cri hardened +seccomp selinux test"
+
+DEPEND="
+ btrfs? ( sys-fs/btrfs-progs )
+ seccomp? ( sys-libs/libseccomp )
+"
+
+RDEPEND="
+ ${DEPEND}
+ ~app-emulation/runc-1.0.0_rc10
+"
+
+BDEPEND="
+ dev-go/go-md2man
+ virtual/pkgconfig
+ test? ( "${RDEPEND}" )
+"
+
+# tests require root or docker
+# upstream does not recommend stripping binary
+RESTRICT+=" strip test"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_prepare() {
+ default
+ sed -i -e "s/git describe --match.*$/echo ${PV})/"\
+ -e "s/git rev-parse HEAD.*$/echo ${CONTAINERD_COMMIT})/"\
+ -e "s/-s -w//" \
+ Makefile || die
+}
+
+src_compile() {
+ local options=(
+ $(usev apparmor)
+ $(usex btrfs "" "no_btrfs")
+ $(usex cri "" "no_cri")
+ $(usex device-mapper "" "no_devmapper")
+ $(usev seccomp)
+ $(usev selinux)
+ )
+
+ myemakeargs=(
+ BUILDTAGS="${options[*]}"
+ DESTDIR="${ED}"
+ LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '')
+ )
+
+ export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+ export GOFLAGS="-v -x -mod=vendor"
+ emake "${myemakeargs[@]}" all man
+}
+
+src_install() {
+ dobin bin/*
+ doman man/*
+ newinitd "${FILESDIR}"/${PN}.initd "${PN}"
+ keepdir /var/lib/containerd
+
+ # we already installed manpages, remove markdown source
+ # before installing docs directory
+ rm -rf docs/man || die
+ local DOCS=( README.md PLUGINS.md docs/. )
+ einstalldocs
+}