summaryrefslogtreecommitdiff
path: root/app-emulation/containerd/containerd-0.2.9_p20170605.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-02 14:45:16 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-02 14:45:16 +0000
commita70f42c65202d88c203c40910fef8f96f333d1ee (patch)
treede550ee3deb79c550ae1aba7fcce118d5d4dbc31 /app-emulation/containerd/containerd-0.2.9_p20170605.ebuild
parent721254b86a09bdedd5eefd0de7899c90ea2ead1a (diff)
gentoo resync : 02.01.2018
Diffstat (limited to 'app-emulation/containerd/containerd-0.2.9_p20170605.ebuild')
-rw-r--r--app-emulation/containerd/containerd-0.2.9_p20170605.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/app-emulation/containerd/containerd-0.2.9_p20170605.ebuild b/app-emulation/containerd/containerd-0.2.9_p20170605.ebuild
deleted file mode 100644
index e574004b67ee..000000000000
--- a/app-emulation/containerd/containerd-0.2.9_p20170605.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-EGO_PN="github.com/${PN}/${PN}"
-
-inherit toolchain-funcs
-
-if [[ ${PV} == *9999 ]]; then
- inherit golang-vcs
-else
- MY_PV="${PV/_/-}"
- EGIT_COMMIT="6e23458c129b551d5c9871e5174f6b1b7f6d1170"
- SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~ppc64"
- inherit golang-vcs-snapshot
-fi
-
-DESCRIPTION="A daemon to control runC"
-HOMEPAGE="https://containerd.tools"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="hardened +seccomp"
-
-DEPEND=""
-RDEPEND=">=app-emulation/docker-runc-1.0.0_rc3_p20170706
- seccomp? ( sys-libs/libseccomp )"
-
-S=${WORKDIR}/${P}/src/${EGO_PN}
-
-RESTRICT="test"
-
-src_compile() {
- local options=( $(usex seccomp "seccomp" '') )
- export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
- LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
-}
-
-src_install() {
- dobin bin/containerd* bin/ctr
-}