summaryrefslogtreecommitdiff
path: root/app-emulation/conmon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /app-emulation/conmon
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'app-emulation/conmon')
-rw-r--r--app-emulation/conmon/Manifest3
-rw-r--r--app-emulation/conmon/conmon-0.2.0.ebuild41
-rw-r--r--app-emulation/conmon/metadata.xml11
3 files changed, 55 insertions, 0 deletions
diff --git a/app-emulation/conmon/Manifest b/app-emulation/conmon/Manifest
new file mode 100644
index 000000000000..024cb9a3d522
--- /dev/null
+++ b/app-emulation/conmon/Manifest
@@ -0,0 +1,3 @@
+DIST conmon-0.2.0.tar.gz 48349 BLAKE2B f61d1750437102c3772669ac8cff75204bf6811a221212cb7127a439b57b70afacb460f4128413e242ccceb0fe44c417dcd0a7f08536f272131704f3a6cbd599 SHA512 81b6eb88a473c6b4e349e18ba48682dd15f5f1ad841d2ca6bead8b5f9b418dd20832a855a1c8d81ac77562d00cb6e5852aab4f6f4ce15f099ca63a0a3f432ec8
+EBUILD conmon-0.2.0.ebuild 929 BLAKE2B 8cebe07ee1dd31992efb45a3c35a1564c7806453d5c60d6f5a89a381a5c30476fae984736252f6868062161a462d7f2070ca796da3e49f54e921dd2146e03aa5 SHA512 08fefcc27c504946f006c5edd0c8a96fd55ae55db6208fdc865dbc65202f23eb79de876d2778c2c6dc3ee194227f6dfbe27dbf10aef98d24154405fba9337a11
+MISC metadata.xml 326 BLAKE2B 88e40bbfd92c360f7ed559dc1f3ebe8d35a4905c413de8208a72e255e531d32f61dea3ad710b3a2743df01b29f3f5426440beff3ffcd59139d6f5ce118c17557 SHA512 0709bf7dd7300225974bbf974a3c90c27a368ae6862e080c95f0fb30f314b94c0502258773649fe2cdeba22ad9f5c0d29d000f95e8f7d961e9cdfbea108b4775
diff --git a/app-emulation/conmon/conmon-0.2.0.ebuild b/app-emulation/conmon/conmon-0.2.0.ebuild
new file mode 100644
index 000000000000..b529698cd21c
--- /dev/null
+++ b/app-emulation/conmon/conmon-0.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+DESCRIPTION="An OCI container runtime monitor"
+HOMEPAGE="https://github.com/containers/conmon"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="systemd"
+EGIT_COMMIT="59952292a3b07ac125575024ae21956efe0ecdfb"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RDEPEND="dev-libs/glib:=
+ systemd? ( sys-apps/systemd:= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if ! use systemd; then
+ sed -e 's| pkg-config --exists libsystemd-journal | false |' \
+ -e 's| pkg-config --exists libsystemd | false |' \
+ -i Makefile || die
+ fi
+}
+
+src_compile() {
+ emake GIT_COMMIT="${EGIT_COMMIT}" \
+ all
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ PREFIX="${ED}/usr" \
+ install
+ mv "${ED}/usr/libexec"/{crio,podman} || die
+ dodir /usr/bin
+ ln "${ED}/usr/"{libexec/podman,bin}/conmon || die
+ dodoc README.md
+}
diff --git a/app-emulation/conmon/metadata.xml b/app-emulation/conmon/metadata.xml
new file mode 100644
index 000000000000..15f05bae08e9
--- /dev/null
+++ b/app-emulation/conmon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">containers/conmon</remote-id>
+ </upstream>
+</pkgmetadata>