summaryrefslogtreecommitdiff
path: root/app-emulation/coldfire
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/coldfire
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/coldfire')
-rw-r--r--app-emulation/coldfire/Manifest5
-rw-r--r--app-emulation/coldfire/coldfire-0.3.1.ebuild26
-rw-r--r--app-emulation/coldfire/files/coldfire-0.3.1-build.patch32
-rw-r--r--app-emulation/coldfire/files/coldfire-0.3.1-headers.patch16
-rw-r--r--app-emulation/coldfire/metadata.xml8
5 files changed, 87 insertions, 0 deletions
diff --git a/app-emulation/coldfire/Manifest b/app-emulation/coldfire/Manifest
new file mode 100644
index 000000000000..6c830117a5ba
--- /dev/null
+++ b/app-emulation/coldfire/Manifest
@@ -0,0 +1,5 @@
+AUX coldfire-0.3.1-build.patch 693 BLAKE2B 0b9ff6d289ea6e67403b895d7f85986601777473b75742bd44898739117be6697ea5785d25a1102f3994dfcaa003f1041f511df45f11050d5cb0c67bb9589cc8 SHA512 1999aa892c62f2ae98062bcd7711f0d120e7ba3fe7b812b236c82f9ecbe48654cc3782e5384a2d57c0e3d503e0df638f2d9efbbd8345becd36959ba1c54d456d
+AUX coldfire-0.3.1-headers.patch 386 BLAKE2B 8b4dd43d49064e9abb9c22685aaac946cf703988303337f206b8975c27d840d0f97b06c68cd11b877da77ed5cfbc9a1e0a1776d39c1db54fa8e501c6b7ffe11e SHA512 5a9c4aa70891421cdff2ef16a49c67483c95e95a88af2a26412e1a6d5161a2cef328a81f891560ede52126eb3b01a3285553e0673fe9e44ae659a35cad701a1d
+DIST coldfire-0.3.1.tar.gz 142964 BLAKE2B b2ec1d9a46b09426caada3cf2216e1aad6eadfc2756c7ea47236f6cebb51b2d09faf6d1e30af240656bc4ec876f425b049e6971e5ab532ceae66b4d80ab41585 SHA512 e9ac6fcd4a9a8cf0998a658c786f91f6d97dbe03cd32fdc7047c87baa14d412a45dfdd233f68e3136e8d0f36c4d6dd556e5df6e8a0645f82d4abf88fa574ff7b
+EBUILD coldfire-0.3.1.ebuild 520 BLAKE2B 4cf2d90103c27adf07cf668304e0987c1431b6503b016575fd87fd91c420e52baeee8903089fe3e50dbc8abc9c90cb6924a1f0639075374a2fcb933d6d8672f9 SHA512 7f1a7142e1a9d5b4bf1bcc2a37ad3a18ad147b8dca566ffb74f87eb387462ac19240f6ab7b0bd15698dc16298903425e961eb8f7de2e8f1fc63d3c0a2b6cc91a
+MISC metadata.xml 247 BLAKE2B e46b8f2d053251af5cb591bb2ee5e35089c4e8174ee2e7a3c504db23f844b65083d4a3e5198da3977ad3e98b67cab2e0de686a3c62009b487c1e64785a8ff65d SHA512 15df289e0f962f564551f61ada3cfef0311f6af639887def780bf5ad3be105515c8d24c950ff340ed35d89b9cd994af3540322b684c5dec3b43ec6bb0041aa4e
diff --git a/app-emulation/coldfire/coldfire-0.3.1.ebuild b/app-emulation/coldfire/coldfire-0.3.1.ebuild
new file mode 100644
index 000000000000..21e971272979
--- /dev/null
+++ b/app-emulation/coldfire/coldfire-0.3.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Motorola Coldfire Emulator"
+HOMEPAGE="http://www.slicer.ca/coldfire/"
+SRC_URI="http://www.slicer.ca/coldfire/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses:0=
+ sys-libs/readline:0="
+
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+ "${FILESDIR}/${P}-headers.patch"
+)
+
+src_install() {
+ dobin coldfire
+ dodoc CONTRIBUTORS HACKING README
+}
diff --git a/app-emulation/coldfire/files/coldfire-0.3.1-build.patch b/app-emulation/coldfire/files/coldfire-0.3.1-build.patch
new file mode 100644
index 000000000000..2b54dd4a16f5
--- /dev/null
+++ b/app-emulation/coldfire/files/coldfire-0.3.1-build.patch
@@ -0,0 +1,32 @@
+respect env build settings
+
+--- a/Makefile.rules.in
++++ b/Makefile.rules.in
+@@ -1,9 +1,9 @@
+ CC = @CC@
+-CFLAGS = -Wall -fomit-frame-pointer @CFLAGS@ -I$(TOPSRCDIR)
++CFLAGS = -Wall @CPPFLAGS@ @CFLAGS@ -I$(TOPSRCDIR)
+ LIBS = @LIBS@
+ LD_R = ld -r
+ RM = rm -f
+-LDFLAGS =
++LDFLAGS = @LDFLAGS@
+
+
+ prefix = @prefix@
+
+fix parallel build problems ... objs need generated tracer, and coldfire
+needs subdir objs
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -22,7 +22,8 @@
+ #Force version to be made before subdirectories
+ subdirs-all: version.h
+
+-coldfire: $(OBJS) force
++$(OBJS): | subdirs-all
++coldfire: $(OBJS) force | subdirs-all
+ $(CC) $(LDFLAGS) $(OBJS) $(SUBDIR_OBJS) -o $@ $(LIBS)
+
+
diff --git a/app-emulation/coldfire/files/coldfire-0.3.1-headers.patch b/app-emulation/coldfire/files/coldfire-0.3.1-headers.patch
new file mode 100644
index 000000000000..706b1a2b12c9
--- /dev/null
+++ b/app-emulation/coldfire/files/coldfire-0.3.1-headers.patch
@@ -0,0 +1,16 @@
+make sure we have access to HAVE_* defines to include header files:
+
+run.c: In function ‘sigint’:
+run.c:51:2: warning: implicit declaration of function ‘readline’
+run.c:51:8: warning: cast to pointer from integer of different size
+
+--- a/run.c
++++ b/run.c
+@@ -7,6 +7,7 @@
+ /**********************************/
+
+
++#include "config.h"
+
+ #include <stdio.h>
+ #include <stdlib.h>
diff --git a/app-emulation/coldfire/metadata.xml b/app-emulation/coldfire/metadata.xml
new file mode 100644
index 000000000000..71b1461e1146
--- /dev/null
+++ b/app-emulation/coldfire/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>embedded@gentoo.org</email>
+ <name>Embedded Gentoo</name>
+</maintainer>
+</pkgmetadata>