summaryrefslogtreecommitdiff
path: root/app-emulation/cloud-hypervisor/cloud-hypervisor-31.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-18 23:56:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-18 23:56:27 +0100
commit93d0bbd7df69c2081c2b2347ea6c88b8e967d537 (patch)
tree5a3d99a67d4243c300c70a88d52d651c1de4688d /app-emulation/cloud-hypervisor/cloud-hypervisor-31.0.ebuild
parentb481b54b8432c46df354eedc3532b0420a38fd5a (diff)
gentoo auto-resync : 18:04:2023 - 23:56:26
Diffstat (limited to 'app-emulation/cloud-hypervisor/cloud-hypervisor-31.0.ebuild')
-rw-r--r--app-emulation/cloud-hypervisor/cloud-hypervisor-31.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-emulation/cloud-hypervisor/cloud-hypervisor-31.0.ebuild b/app-emulation/cloud-hypervisor/cloud-hypervisor-31.0.ebuild
new file mode 100644
index 000000000000..658d5b70d049
--- /dev/null
+++ b/app-emulation/cloud-hypervisor/cloud-hypervisor-31.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Auto-Generated by cargo-ebuild 0.5.4
+
+EAPI=8
+
+CRATES=" "
+inherit cargo
+
+DESCRIPTION="Open source Virtual Machine Monitor (VMM) that runs on top of KVM"
+HOMEPAGE="https://www.cloudhypervisor.org"
+SRC_URI="https://github.com/cloud-hypervisor/cloud-hypervisor/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~jsmolic/distfiles/${P}-vendor.tar.gz"
+
+LICENSE="0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD Boost-1.0 MIT MPL-2.0 Unicode-DFS-2016 Unlicense ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# rust does not use *FLAGS from make.conf, silence portage warning
+# update with proper path to binaries this crate installs, omit leading /
+QA_FLAGS_IGNORED="usr/bin/${PN}"
+
+src_unpack() {
+ cargo_src_unpack
+ mkdir "${S}"/{vendor,.cargo} || die
+ ln -s "${WORKDIR}/vendor/"* "${S}"/vendor || die
+ cp "${FILESDIR}"/${P}-vendor-config "${S}"/.cargo/config.toml || die
+}
+
+src_prepare() {
+ default
+ sed -i 's/strip = true/strip = false/' Cargo.toml || die
+}
+
+src_configure() {
+ cargo_gen_config
+ cargo_src_configure --frozen
+}
+
+src_install() {
+ cargo_src_install
+ dodoc -r docs
+}