summaryrefslogtreecommitdiff
path: root/app-emulation/buildah
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-15 13:19:56 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-15 13:19:56 +0100
commitd302a5d7fc9caafba5c8a404f2891bb6ccdec311 (patch)
tree2a3ee43f080d1d0086964de8c29ccf1021fdfda7 /app-emulation/buildah
parentea31ad0ed5501d0bf92267c35beaf06ac016bad2 (diff)
gentoo resync : 15.05.2018
Diffstat (limited to 'app-emulation/buildah')
-rw-r--r--app-emulation/buildah/Manifest3
-rw-r--r--app-emulation/buildah/buildah-1.0.ebuild46
-rw-r--r--app-emulation/buildah/metadata.xml11
3 files changed, 60 insertions, 0 deletions
diff --git a/app-emulation/buildah/Manifest b/app-emulation/buildah/Manifest
new file mode 100644
index 000000000000..7b5ba7a3451a
--- /dev/null
+++ b/app-emulation/buildah/Manifest
@@ -0,0 +1,3 @@
+DIST buildah-1.0.tar.gz 2865669 BLAKE2B 7749ed00637fff9c2bcee63ef9e8985b3e6e2abff1c1f4787dc0730b9765576fac9173dd05cbc289aed3c0d20ff374a78976beb86c73adb221184415e4906a41 SHA512 17779e5bbc20fff6da607898620a8193e11ef13ddc033e7868776aab53a710e09428dca0450f11368d750bf7179fd4850ac3a8a445bd9537d987bd837853f4e5
+EBUILD buildah-1.0.ebuild 1030 BLAKE2B 6433baa65962203139b9ff71c665f46d7de0a6d74e90c55cf32c9a0559af94d3eb7b3707f4184c83902e92231bbdebae3769b83110dfe41570e5642e25b45a8d SHA512 207cb4e59bfa5f233fe0c97ddb967ff9521b4e16828e9a7186a2c93968b6c2e14d5dd41185bcd0e45096dde0d00eeb3c848490db1fe6400c35110786e21129f6
+MISC metadata.xml 330 BLAKE2B 0be4a049ad821a2355b1d5ac21ae58def26c7f3310a56c7b870c25e6c018f1bc6147c59bfdc42885ba4f8238538d69e31928f35f002ec5ba684da87673b8f87c SHA512 c8c1341578b493bc9b68d615fb68232bed4369a60b839e397ba03e330f452e23124e180ee804a3fb1708169382aa65046931bc480f2690f37c3f698c12a94963
diff --git a/app-emulation/buildah/buildah-1.0.ebuild b/app-emulation/buildah/buildah-1.0.ebuild
new file mode 100644
index 000000000000..baf50ef426d8
--- /dev/null
+++ b/app-emulation/buildah/buildah-1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit bash-completion-r1 golang-vcs-snapshot
+
+KEYWORDS="~amd64"
+DESCRIPTION="A tool that facilitates building OCI images"
+HOMEPAGE="https://github.com/projectatomic/buildah"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+EGO_PN="${HOMEPAGE#*//}"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="1ab80bc"
+SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+RDEPEND="app-crypt/gpgme:=
+ app-emulation/skopeo
+ dev-libs/libgpg-error:=
+ dev-libs/libassuan:=
+ sys-fs/lvm2:=
+ sys-libs/libseccomp:="
+DEPEND="${RDEPEND}"
+RESTRICT="test"
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_prepare() {
+ default
+ sed -e 's|^\(GIT_COMMIT := \).*|\1'${GIT_COMMIT}'|' -i Makefile || die
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}" emake all
+}
+
+src_install() {
+ dodoc README.md
+ doman docs/*.1
+ dodoc -r docs/tutorials
+ dobin ${PN} imgtype
+ dobashcomp contrib/completions/bash/buildah
+}
+
+src_test() {
+ GOPATH="${WORKDIR}/${P}" emake test-unit
+}
diff --git a/app-emulation/buildah/metadata.xml b/app-emulation/buildah/metadata.xml
new file mode 100644
index 000000000000..07a3ba13a110
--- /dev/null
+++ b/app-emulation/buildah/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">projectatomic/buildah</remote-id>
+ </upstream>
+</pkgmetadata>