summaryrefslogtreecommitdiff
path: root/app-emulation/aqemu/aqemu-0.9.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/aqemu/aqemu-0.9.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/aqemu/aqemu-0.9.2.ebuild')
-rw-r--r--app-emulation/aqemu/aqemu-0.9.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-emulation/aqemu/aqemu-0.9.2.ebuild b/app-emulation/aqemu/aqemu-0.9.2.ebuild
new file mode 100644
index 000000000000..dc50e71ce8f6
--- /dev/null
+++ b/app-emulation/aqemu/aqemu-0.9.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Graphical interface for QEMU and KVM emulators, using Qt5"
+HOMEPAGE="https://sourceforge.net/projects/aqemu"
+SRC_URI="https://github.com/tobimensch/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="vnc"
+
+DEPEND="${RDEPEND}"
+RDEPEND="app-emulation/qemu
+ vnc? ( net-libs/libvncserver )
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtnetwork:5
+ dev-qt/qttest:5
+ dev-qt/qtprintsupport:5"
+
+DOCS="AUTHORS CHANGELOG README TODO"
+PATCHES=( "${FILESDIR}/${PN}-0.9.2-qtbindir.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ "-DMAN_PAGE_COMPRESSOR="
+ "-DWITHOUT_EMBEDDED_DISPLAY=$(usex vnc "OFF" "ON")"
+ )
+
+ cmake-utils_src_configure
+}