summaryrefslogtreecommitdiff
path: root/app-emacs/yc/yc-5.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-emacs/yc/yc-5.2.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-emacs/yc/yc-5.2.1.ebuild')
-rw-r--r--app-emacs/yc/yc-5.2.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/yc/yc-5.2.1.ebuild b/app-emacs/yc/yc-5.2.1.ebuild
new file mode 100644
index 000000000000..eb6992a1aa20
--- /dev/null
+++ b/app-emacs/yc/yc-5.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit elisp
+
+DESCRIPTION="Yet another Canna client on Emacsen"
+HOMEPAGE="http://www.ceres.dti.ne.jp/~knak/yc.html"
+SRC_URI="http://www.ceres.dti.ne.jp/~knak/${P}.el.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="app-i18n/canna"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+
+ dodoc "${FILESDIR}"/sample.{dot.emacs,hosts.canna}
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ elog "See the sample.dot.emacs in ${EPREFIX}/usr/share/doc/${PF}."
+ elog
+ elog "And If you use unix domain socket for connecting the canna server,"
+ elog "please confirm that there's *no* following line in your ~/.emacs:"
+ elog ' (setq yc-server-host "localhost")'
+ elog
+ elog "If you use inet domain socket for connecting the canna server,"
+ elog "please modify as following in ${EPREFIX}/etc/conf.d/canna:"
+ elog ' CANNASERVER_OPTS="-inet"'
+ elog
+ elog "And create ${EPREFIX}/etc/hosts.canna."
+ elog "See the sample.hosts.canna in ${EPREFIX}/usr/share/doc/${PF}."
+}