summaryrefslogtreecommitdiff
path: root/app-emacs/yatex/yatex-1.80.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /app-emacs/yatex/yatex-1.80.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'app-emacs/yatex/yatex-1.80.ebuild')
-rw-r--r--app-emacs/yatex/yatex-1.80.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-emacs/yatex/yatex-1.80.ebuild b/app-emacs/yatex/yatex-1.80.ebuild
new file mode 100644
index 000000000000..70503b9d1dff
--- /dev/null
+++ b/app-emacs/yatex/yatex-1.80.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit elisp
+
+DESCRIPTION="Yet Another TeX mode for Emacs"
+HOMEPAGE="http://www.yatex.org/"
+SRC_URI="http://www.${PN}.org/${P/-}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE="l10n_ja"
+
+S="${WORKDIR}/${P/-}"
+
+ELISP_PATCHES="${PN}-1.76-direntry.patch
+ ${P}-texinfo-5.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ sed -i "/(help-dir/,/)))/c\ (help-dir \"${SITEETC}/${PN}\"))" ${PN}hlp.el
+
+ elisp_src_prepare
+}
+
+src_compile() {
+ cd docs
+ makeinfo {${PN},yahtml}e.tex || die
+
+ if use l10n_ja; then
+ iconv -f WINDOWS-31J -t UTF-8 ${PN}j.tex > ${PN}-ja.texi || die
+ iconv -f WINDOWS-31J -t UTF-8 yahtmlj.tex > yahtml-ja.texi || die
+ makeinfo {${PN},yahtml}-ja.texi || die
+ fi
+}
+
+src_install() {
+ elisp-install ${PN} *.el
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+
+ insinto ${SITEETC}/${PN}
+ doins help/YATEXHLP.eng
+ doinfo docs/{${PN},yahtml}.info*
+ dodoc install docs/*.eng
+
+ if use l10n_ja; then
+ doins help/YATEXHLP.jp
+ doinfo docs/{${PN},yahtml}-ja.info*
+ dodoc 00readme ${PN}.new docs/{htmlqa,qanda,*.doc}
+ fi
+}