summaryrefslogtreecommitdiff
path: root/app-emacs/yasnippet-snippets
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-05 00:07:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-05 00:07:53 +0100
commit9d1e33edaf09cde926d589461f40e378d4124be9 (patch)
treeb0a5a85acd92ce912a95245121dde9cebcf76b71 /app-emacs/yasnippet-snippets
parentdafa6f367240d1f5329ca89fb6f78985dbdc025b (diff)
gentoo auto-resync : 05:06:2024 - 00:07:52
Diffstat (limited to 'app-emacs/yasnippet-snippets')
-rw-r--r--app-emacs/yasnippet-snippets/Manifest2
-rw-r--r--app-emacs/yasnippet-snippets/yasnippet-snippets-1.1.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/app-emacs/yasnippet-snippets/Manifest b/app-emacs/yasnippet-snippets/Manifest
index 0ae7bc2aaa0d..b2800653839b 100644
--- a/app-emacs/yasnippet-snippets/Manifest
+++ b/app-emacs/yasnippet-snippets/Manifest
@@ -1,5 +1,7 @@
AUX 50yasnippet-snippets-gentoo.el 221 BLAKE2B 608ecd2c72d3ff72c7775bfaeb3edbbc4e066a7ed9e1f10720fb93023319e0141e9694c6bbbb697264b62f9f47721f2f0ac186286a38d1859bf3e5529e8ae118 SHA512 a7a89ab8d5e0c66ada64b04b9bc0917df6c20537c80cebea43ee1210635b20e8b34549455c21217fdaa169dc5eafaa9c5c0032605a17716276437e982653428d
AUX yasnippet-snippets-dir.patch 523 BLAKE2B b9e0712cae1b65b947b04d5349bb25007ee6f7db0cd8dd56ff7db15192932d88f7c9ab1b1fca77fca450152a52ec19f275f568f947879eab68b755731b48a5ad SHA512 f1a2c1c3db8a752a38e32147d2a8ffbae0666de4657b647ee126b96db0e4a499384148e3d316a72dcfdb5083c06c7c9eb0a47f329a24ac68532052acf994f79d
DIST yasnippet-snippets-1.0.tar.gz 178027 BLAKE2B 0b44c94c3ad3f2a1208aefba110945aeae74e7278c93078c59677985efc89767b670c99b4b8303b56ea0b748375762ada1e45653e02922b248273af5818514d4 SHA512 2df010f24e51d0156bcb3d488cd6a63a47d2d92e4c5f3cd081e377dc91426d630bde41db6f79d1b5ac1e932e4d0ab11f9be945e94fb35d50b1789adab19bd15b
+DIST yasnippet-snippets-1.1.tar.gz 179315 BLAKE2B 23413fa35612a8583d3919ce1597e7519d0f4f28a537d8fc18f09d3bd1213c161f3f5987bcd727b73bddd3a94098059e8ba284b4491b3fec528465c840518565 SHA512 4f2fa91e9749e4035fcf643a3ef319bbadabe9b07630db4615da9ae2df8784b3c1155ebae83764e7ed7b0db957a80c97451de388b129438955d6aacf25753bc2
EBUILD yasnippet-snippets-1.0-r2.ebuild 882 BLAKE2B b1d01e75ada8536ea229ae50726f0093012cb92da246ff7f83611aa7205811ec95078e52503bff0e4b6ef70a5e7adad458cfc6b1d311d029d06b8b5588ca0c03 SHA512 fdb8ff6bb006c81db3f5d19b16b91822c5f54e99953466e4a28fe59a7659dc46b1638766ec4d838ce1205933346cfaa31b36ab9ee127e30a6594fcf36e29559f
+EBUILD yasnippet-snippets-1.1.ebuild 1019 BLAKE2B c7b2cf7b2d651917ad7a5f972883796e83cd306642a7b27c1091d4a20b511092a6040dece12b62ce3804a3e8008841edaad1e1526ce7f185b1ee19ce2aaf22da SHA512 49bcade5b17af18b1a2c5892f9399a9b44ae9963f3a1e3326b4576936310b2be161981c7be9f82caf1dbde9b6dc1ef37fe121dceddb5b58b75398e55800b5956
MISC metadata.xml 377 BLAKE2B 78f369ac63a6ba16eabfbc21367b0e29221a94a8460b877e58b23e4c4176e3d4393ac7cb657057fe239298fc9836365b8a5d6ec789251ed552e684590b40e6e4 SHA512 72e8f247f2bb604ea52229c1aa68abf0fdd6649c87ffaad7f2893131f522cc3d7283251d8e365def16ac5eea831c98472a0ebe591cb6188132e0d7696b559b55
diff --git a/app-emacs/yasnippet-snippets/yasnippet-snippets-1.1.ebuild b/app-emacs/yasnippet-snippets/yasnippet-snippets-1.1.ebuild
new file mode 100644
index 000000000000..13490ccc3e98
--- /dev/null
+++ b/app-emacs/yasnippet-snippets/yasnippet-snippets-1.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp edo
+
+DESCRIPTION="A collection of yasnippet snippets for many languages"
+HOMEPAGE="https://github.com/AndreaCrotti/yasnippet-snippets"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/AndreaCrotti/${PN}.git"
+else
+ SRC_URI="https://github.com/AndreaCrotti/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/yasnippet
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${PN}-dir.patch" )
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed "s|@SITEETC@|${EPREFIX}${SITEETC}/${PN}|" -i "${PN}.el" || die
+}
+
+src_compile() {
+ elisp_src_compile
+
+ edo ${EMACS} ${EMACSFLAGS} \
+ --eval "(require 'yasnippet)" \
+ --eval "(yas-compile-directory \"${S}/snippets\")"
+}
+
+src_install() {
+ elisp_src_install
+
+ insinto "${SITEETC}/${PN}"
+ doins -r snippets
+}