summaryrefslogtreecommitdiff
path: root/app-emacs/xelb/xelb-0.19.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-28 12:00:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-28 12:00:19 +0100
commit7166f3a0a0b7886d340010458d0b130013cb9989 (patch)
tree3ff502007dde9dba943a004a3bf201ae4e0787bd /app-emacs/xelb/xelb-0.19.ebuild
parent345c02ca33341652116ddec6705530223af2de85 (diff)
gentoo auto-resync : 28:08:2024 - 12:00:19
Diffstat (limited to 'app-emacs/xelb/xelb-0.19.ebuild')
-rw-r--r--app-emacs/xelb/xelb-0.19.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/xelb/xelb-0.19.ebuild b/app-emacs/xelb/xelb-0.19.ebuild
new file mode 100644
index 000000000000..ee22f549a253
--- /dev/null
+++ b/app-emacs/xelb/xelb-0.19.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="X protocol Emacs Lisp Binding"
+HOMEPAGE="https://github.com/emacs-exwm/xelb/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/emacs-exwm/${PN}.git"
+else
+ SRC_URI="https://github.com/emacs-exwm/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-editors/emacs[gui]
+ x11-apps/xauth
+"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"