summaryrefslogtreecommitdiff
path: root/app-emacs/vhdl-mode/vhdl-mode-3.38.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /app-emacs/vhdl-mode/vhdl-mode-3.38.3.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'app-emacs/vhdl-mode/vhdl-mode-3.38.3.ebuild')
-rw-r--r--app-emacs/vhdl-mode/vhdl-mode-3.38.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/vhdl-mode/vhdl-mode-3.38.3.ebuild b/app-emacs/vhdl-mode/vhdl-mode-3.38.3.ebuild
new file mode 100644
index 000000000000..5099ff5fbfd8
--- /dev/null
+++ b/app-emacs/vhdl-mode/vhdl-mode-3.38.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="VHDL-mode for Emacs"
+HOMEPAGE="https://iis-people.ee.ethz.ch/~zimmi/emacs/vhdl-mode.html"
+SRC_URI="https://iis-people.ee.ethz.ch/~zimmi/emacs/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-emacs-28.patch
+ "${FILESDIR}"/${PN}-info-dir-gentoo.patch
+)
+ELISP_REMOVE="site-start.*"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="ChangeLog README"
+
+src_install() {
+ elisp_src_install
+ doinfo vhdl-mode.info
+}