summaryrefslogtreecommitdiff
path: root/app-emacs/vertico/vertico-1.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-04 10:56:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-04 10:56:18 +0000
commit4ead5818a5d230bcc875202c487761a9b786e945 (patch)
tree63238d1977f2788cb5b7074037f15810af25bb88 /app-emacs/vertico/vertico-1.5.ebuild
parentd074d0ba59e3121dba0c27c4a18f1e481f67b62a (diff)
gentoo auto-resync : 04:12:2023 - 10:56:18
Diffstat (limited to 'app-emacs/vertico/vertico-1.5.ebuild')
-rw-r--r--app-emacs/vertico/vertico-1.5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/vertico/vertico-1.5.ebuild b/app-emacs/vertico/vertico-1.5.ebuild
new file mode 100644
index 000000000000..8623d46e2c78
--- /dev/null
+++ b/app-emacs/vertico/vertico-1.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Vertical interactive completion"
+HOMEPAGE="https://github.com/minad/vertico/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-29.1.4.0"
+BDEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG.org README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ mv extensions/*.el ./ || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}