summaryrefslogtreecommitdiff
path: root/app-emacs/vertico/vertico-1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-27 00:16:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-27 00:16:04 +0100
commitc23a7f2796a181331872d4c55ea25940d1386b3d (patch)
treeffa1726031deb55edde1547a8f4ca5fcb9d2b7db /app-emacs/vertico/vertico-1.3.ebuild
parent495a8590505b434749ddebe6aa159b4d707ed846 (diff)
gentoo auto-resync : 27:04:2023 - 00:16:04
Diffstat (limited to 'app-emacs/vertico/vertico-1.3.ebuild')
-rw-r--r--app-emacs/vertico/vertico-1.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/vertico/vertico-1.3.ebuild b/app-emacs/vertico/vertico-1.3.ebuild
new file mode 100644
index 000000000000..0ff52c845500
--- /dev/null
+++ b/app-emacs/vertico/vertico-1.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Vertical interactive completion"
+HOMEPAGE="https://github.com/minad/vertico"
+SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=app-emacs/compat-29.1.4.0"
+BDEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG.org README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ mv extensions/*.el ./ || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}