summaryrefslogtreecommitdiff
path: root/app-emacs/vertico/vertico-0.28.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-20 01:59:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-20 01:59:18 +0100
commit9ed0c42eb618229fa6f45e10155ee535e1f605a2 (patch)
tree1cee221ce6610b86c942bdb5bd12aee04ac18642 /app-emacs/vertico/vertico-0.28.ebuild
parentadab5aeec61fe929e5a817ec8034d98caab9ddbe (diff)
gentoo auto-resync : 20:10:2022 - 01:59:18
Diffstat (limited to 'app-emacs/vertico/vertico-0.28.ebuild')
-rw-r--r--app-emacs/vertico/vertico-0.28.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/vertico/vertico-0.28.ebuild b/app-emacs/vertico/vertico-0.28.ebuild
new file mode 100644
index 000000000000..eec14ff439d5
--- /dev/null
+++ b/app-emacs/vertico/vertico-0.28.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27
+
+inherit elisp
+
+DESCRIPTION="Vertical interactive completion"
+HOMEPAGE="https://github.com/minad/vertico"
+SRC_URI="https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ mv extensions/*.el . || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}