summaryrefslogtreecommitdiff
path: root/app-emacs/treesit-auto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-28 09:49:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-28 09:49:11 +0100
commit115dcc7054f5934a2c8e26fd8a8eed5f3e29e9ce (patch)
treec31afe35699960753f76770d6b0b4ea48af9f686 /app-emacs/treesit-auto
parente292b671b113c2cc012beddad93a3df4f9410698 (diff)
gentoo auto-resync : 28:03:2023 - 09:49:10
Diffstat (limited to 'app-emacs/treesit-auto')
-rw-r--r--app-emacs/treesit-auto/Manifest4
-rw-r--r--app-emacs/treesit-auto/files/50treesit-auto-gentoo.el1
-rw-r--r--app-emacs/treesit-auto/metadata.xml16
-rw-r--r--app-emacs/treesit-auto/treesit-auto-0.6.3.ebuild25
4 files changed, 46 insertions, 0 deletions
diff --git a/app-emacs/treesit-auto/Manifest b/app-emacs/treesit-auto/Manifest
new file mode 100644
index 000000000000..f10a139a9bf2
--- /dev/null
+++ b/app-emacs/treesit-auto/Manifest
@@ -0,0 +1,4 @@
+AUX 50treesit-auto-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST treesit-auto-0.6.3.tar.gz 21342 BLAKE2B 291b9c5706cf0a6e329d9be12b89f7cb3b3c9eed7792bec0b0842785a167f053cac3672516adeefc09a81eb7126f7cee8b63810271566dcc93bd6b04ad41f0c5 SHA512 d4dfc081aa632b4582a91c99103afb9ffd11db56d58fa3a9d6693372b640b163d08bd3a2ce7cb384600357dddee02f6c0a73bf940fd4117f01f70811a311d140
+EBUILD treesit-auto-0.6.3.ebuild 651 BLAKE2B f6d6c59283c1ac2c7606c91561b897027e34a6e05845bce210bc98b859d653762adb02bccf6631fd6368b5754601ee7bcb563f157e15d9484f414b7ef52b04c4 SHA512 8c4959dbb97954eebd81cab241eea4822713d76d9258364c378bafbe145631552511f8dfef14aa91373277e0beff01cab30ddc65231ec3e0f738fa6ca0dc3b4a
+MISC metadata.xml 536 BLAKE2B 4c9133240fdea35d96e62e8b0ce2015f6e8eabb51b9ed901053d6db3faf046deb89c5d20f52990d701fb4926419c07ac2da687f360b6ae2ea3d266a4723a37db SHA512 4048878cbd5392edf870ae40713c03bbf6260957492783a5fda5a2b443cee27ee74a4ad7bed9f9c228ef720c5cf10cf09f103ceacd06c81ce8dc0aafff48118d
diff --git a/app-emacs/treesit-auto/files/50treesit-auto-gentoo.el b/app-emacs/treesit-auto/files/50treesit-auto-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/treesit-auto/files/50treesit-auto-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/treesit-auto/metadata.xml b/app-emacs/treesit-auto/metadata.xml
new file mode 100644
index 000000000000..95a10fb31665
--- /dev/null
+++ b/app-emacs/treesit-auto/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/renzmann/treesit-auto/issues/</bugs-to>
+ <remote-id type="github">renzmann/treesit-auto</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/treesit-auto/treesit-auto-0.6.3.ebuild b/app-emacs/treesit-auto/treesit-auto-0.6.3.ebuild
new file mode 100644
index 000000000000..c5c8c00a87ff
--- /dev/null
+++ b/app-emacs/treesit-auto/treesit-auto-0.6.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=29
+inherit elisp
+
+DESCRIPTION="Automatic installation, usage, fallback for tree-sitter modes in Emacs 29"
+HOMEPAGE="https://github.com/renzmann/treesit-auto"
+
+if [[ ${PV} == *_p* ]] ; then
+ MY_COMMIT=""
+ SRC_URI="https://github.com/renzmann/treesit-auto/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${MY_COMMIT}
+else
+ SRC_URI="https://github.com/renzmann/treesit-auto/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+# Needs Emacs 29
+#KEYWORDS="~amd64"
+
+SITEFILE="50${PN}-gentoo.el"