summaryrefslogtreecommitdiff
path: root/app-emacs/treemacs/treemacs-2.9.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-27 03:59:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-27 03:59:18 +0000
commit063e5b486db858a2b1ecec798af89f5484d475bd (patch)
tree490932df05aadb9cbb3611e63a31507953ab5c91 /app-emacs/treemacs/treemacs-2.9.5-r2.ebuild
parenta0953f7ac639d8e180f62ab3364ccf9af71f783d (diff)
gentoo auto-resync : 27:02:2023 - 03:59:17
Diffstat (limited to 'app-emacs/treemacs/treemacs-2.9.5-r2.ebuild')
-rw-r--r--app-emacs/treemacs/treemacs-2.9.5-r2.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/app-emacs/treemacs/treemacs-2.9.5-r2.ebuild b/app-emacs/treemacs/treemacs-2.9.5-r2.ebuild
index 847fece21ce8..1c2b01c56dc4 100644
--- a/app-emacs/treemacs/treemacs-2.9.5-r2.ebuild
+++ b/app-emacs/treemacs/treemacs-2.9.5-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
NEED_EMACS=26.1
DISTUTILS_USE_PEP517=no
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit elisp distutils-r1
@@ -34,14 +34,14 @@ BDEPEND="
test? ( app-emacs/buttercup )
"
-DOCS=( Changelog.org Extensions.org README.org screenshots )
+BYTECOMPFLAGS="-L . -L src/elisp"
PATCHES=(
"${FILESDIR}"/${PN}-async-scripts.patch
"${FILESDIR}"/${PN}-icons-icon-directory.patch
"${FILESDIR}"/${P}-tests.patch
)
-BYTECOMPFLAGS="-L . -L src/elisp"
+DOCS=( Changelog.org Extensions.org README.org screenshots )
SITEFILE="50${PN}-gentoo.el"
src_prepare() {
@@ -58,6 +58,7 @@ python_compile() {
src_compile() {
distutils-r1_src_compile
+
elisp-compile src/elisp/*.el
}