summaryrefslogtreecommitdiff
path: root/app-emacs/treemacs/treemacs-2.9.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-emacs/treemacs/treemacs-2.9.5-r1.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-emacs/treemacs/treemacs-2.9.5-r1.ebuild')
-rw-r--r--app-emacs/treemacs/treemacs-2.9.5-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-emacs/treemacs/treemacs-2.9.5-r1.ebuild b/app-emacs/treemacs/treemacs-2.9.5-r1.ebuild
new file mode 100644
index 000000000000..ea3b8ab8544a
--- /dev/null
+++ b/app-emacs/treemacs/treemacs-2.9.5-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="Tree style project file explorer"
+HOMEPAGE="https://github.com/Alexander-Miller/treemacs/"
+SRC_URI="https://github.com/Alexander-Miller/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-emacs/ace-window
+ app-emacs/cfrs
+ app-emacs/dash
+ app-emacs/ht
+ app-emacs/hydra
+ app-emacs/pfuture
+ app-emacs/s
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( app-emacs/buttercup )
+"
+
+DOCS=( Changelog.org Extensions.org README.org screenshots )
+PATCHES=( "${FILESDIR}"/${PN}-icons-icon-directory.patch )
+
+BYTECOMPFLAGS="-L . -L src/elisp"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed "s|@SITEETC@|${SITEETC}/${PN}|" -i src/elisp/${PN}-icons.el || die
+}
+
+src_compile() {
+ elisp-compile src/elisp/*.el
+}
+
+src_test() {
+ buttercup ${BYTECOMPFLAGS} -L test --traceback full || die
+}
+
+src_install() {
+ elisp-install ${PN} src/elisp/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ insinto ${SITEETC}/${PN}
+ doins -r icons
+}