summaryrefslogtreecommitdiff
path: root/app-emacs/transient/transient-0.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-30 23:09:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-30 23:09:52 +0000
commit19649f88a8fb3ce7dc2db1e6b18a048efb4898b1 (patch)
tree2547760a98afd574f54c3c12f2e68363a1c1abff /app-emacs/transient/transient-0.5.0.ebuild
parentb34c45ec12e8676abfa39cddcf3448ac2bee1574 (diff)
gentoo auto-resync : 30:11:2023 - 23:09:52
Diffstat (limited to 'app-emacs/transient/transient-0.5.0.ebuild')
-rw-r--r--app-emacs/transient/transient-0.5.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/transient/transient-0.5.0.ebuild b/app-emacs/transient/transient-0.5.0.ebuild
new file mode 100644
index 000000000000..8fae47219ad7
--- /dev/null
+++ b/app-emacs/transient/transient-0.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Transient commands abstraction for GNU Emacs"
+HOMEPAGE="https://magit.vc/manual/transient/
+ https://github.com/magit/transient/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG README.org docs/${PN}.org )
+ELISP_TEXINFO="docs/${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND=">=app-emacs/compat-29.1.4.1"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+src_prepare() {
+ mv lisp/*.el . || die
+
+ default
+}