summaryrefslogtreecommitdiff
path: root/app-emacs/thinks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/thinks
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/thinks')
-rw-r--r--app-emacs/thinks/Manifest4
-rw-r--r--app-emacs/thinks/files/50thinks-gentoo.el31
-rw-r--r--app-emacs/thinks/metadata.xml9
-rw-r--r--app-emacs/thinks/thinks-1.9.ebuild17
4 files changed, 61 insertions, 0 deletions
diff --git a/app-emacs/thinks/Manifest b/app-emacs/thinks/Manifest
new file mode 100644
index 000000000000..28d310a8bfdb
--- /dev/null
+++ b/app-emacs/thinks/Manifest
@@ -0,0 +1,4 @@
+AUX 50thinks-gentoo.el 852 BLAKE2B a7418e25b5dac4daed3c9e1e70b689dfa0a9f4087a605ff50ea5fffd25906df22400fcf77066f30c19057a83d8d78c3efd8ac110ef1b0f8d19db95ab2c8f080f SHA512 c82105986cd349a7716ac1ee1b54f16101719aa6f14a3485ec7942b8704c6fd748e5eba708064607c15a50158df64d7591af90a7bdb38ba7e0ed6c0811ca9897
+DIST thinks-1.9.el.bz2 2989 BLAKE2B 91fd4fe2b004625f758f0a3941228c0db6de37c637fcbf0456060e2a2f6e9c3618f6a815d9c649a87da286745f4831df21ebf225947d926f89ae20c49e3e8403 SHA512 ba85485df0decb2825a832b60b01a4ae8ef2e32dc356d16b770a4b59a795e138f3c26e14d8eb27e97038d10d2633945c7b2bd14933fdf7815f6c0abc07de5802
+EBUILD thinks-1.9.ebuild 407 BLAKE2B 6fbeafd2f21aa339197e2054b2379a16552d79ce88d6741323ff234a5839cb7af5f08528a8e3517e5032f15172c6f8ba171d9f2cc2a1f2925147ec9815fc4087 SHA512 1d6dc2def9daeb1fcc27568c46f93ed47f2270b7473788d05788446b63009022d5ec93e9ae99e5fbf7ee670644f385848a683f4da288966f0ce7941c7b374c24
+MISC metadata.xml 282 BLAKE2B 432e60a3b04def9f566fde3852011e006c0d578c72c42115734d1af5c128440fcee68134c8f891baad437e64a8d61fbbac49e70a35ed4f6f85641e888d3a2547 SHA512 1838e22e1f5b849b816a05d1b25bd81333c8cf67ceb996177e05ba7a555b8e0e307e62cb53e6f1217f4216823e2fecf050e85437678503d60e10c6b2d5303072
diff --git a/app-emacs/thinks/files/50thinks-gentoo.el b/app-emacs/thinks/files/50thinks-gentoo.el
new file mode 100644
index 000000000000..e9b9968517ac
--- /dev/null
+++ b/app-emacs/thinks/files/50thinks-gentoo.el
@@ -0,0 +1,31 @@
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload (quote thinks) "thinks" "\
+Insert TEXT wrapped in a think bubble.
+
+Prefix a call to this function with \\[universal-argument] if you don't want
+the text to be filled for you.
+
+\(fn TEXT)" t nil)
+
+(autoload (quote thinks-region) "thinks" "\
+Bubble wrap region bounding START and END.
+
+Prefix a call to this function with \\[universal-argument] if you don't want
+the text to be filled for you.
+
+\(fn START END)" t nil)
+
+(autoload (quote thinks-yank) "thinks" "\
+Do a `yank' and bubble wrap the yanked text.
+
+Prefix a call to this function with \\[universal-argument] if you don't want
+the text to be filled for you.
+
+\(fn)" t nil)
+
+(autoload (quote thinks-maybe-region) "thinks" "\
+If region is active, bubble wrap region bounding START and END.
+If not, query for text to insert in bubble.
+
+\(fn)" t nil)
diff --git a/app-emacs/thinks/metadata.xml b/app-emacs/thinks/metadata.xml
new file mode 100644
index 000000000000..c918cdef9591
--- /dev/null
+++ b/app-emacs/thinks/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+</pkgmetadata>
diff --git a/app-emacs/thinks/thinks-1.9.ebuild b/app-emacs/thinks/thinks-1.9.ebuild
new file mode 100644
index 000000000000..4471d2d43248
--- /dev/null
+++ b/app-emacs/thinks/thinks-1.9.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Insert text in a think bubble"
+HOMEPAGE="http://www.davep.org/emacs/"
+# taken from http://www.davep.org/emacs/${PN}.el
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 x86"
+
+SITEFILE="50${PN}-gentoo.el"