summaryrefslogtreecommitdiff
path: root/app-emacs/shell-split-string/shell-split-string-0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-emacs/shell-split-string/shell-split-string-0.1.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-emacs/shell-split-string/shell-split-string-0.1.ebuild')
-rw-r--r--app-emacs/shell-split-string/shell-split-string-0.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-emacs/shell-split-string/shell-split-string-0.1.ebuild b/app-emacs/shell-split-string/shell-split-string-0.1.ebuild
new file mode 100644
index 000000000000..1538d8985c5d
--- /dev/null
+++ b/app-emacs/shell-split-string/shell-split-string-0.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Split Strings Using Shell-Like Syntax"
+HOMEPAGE="https://github.com/10sr/shell-split-string-el/"
+SRC_URI="https://github.com/10sr/${PN}-el/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-el-${PV}
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ emake emacs=${EMACS} test
+}